Showing results for 
Search instead for 
Did you mean: 

Error when Generating the Program

Former Member
0 Kudos

Recently there was an SP upgrade and my Planning Book started giving me this error message (SCM version =5.0 and SP = 7)

"Error when generating the program" Message no. /SAPAPO/TSM141

Diagnosis: Generated programs are programs that are generated based on individual data objects, such as planning object structure, planning areas and Infocubes. These programs are then executed in the transaction. An error occured during the generation of such a program

Possible causes:

1. The template has been corrupted

2. The object that the template uses to generate the program contains inconsistencies; for instance an Infocube has not been activated


This error occurs when I try to open the my planning book/creating the selection profile. I've re-activated the Infocube and later deactivate and active my POS and tried to do the same for the Planning Area....but the error still persists. I tried to create a new planning area and tried it again but the error still persists. I've tried to fix any inconsistencies in the planning area time series objects by running the consistency check....however the same error pops up during the consistency check....

Anyone encountered this error message and any possible solutions to this issue.



Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

We dont go for any upgrade but i get the same error when i try to load the data from the cube to the planning area.

Pls help me in this .

Former Member
0 Kudos

Closed per information in the thread

Former Member
0 Kudos


I am also getting the same error message when I try to extract the data from a datasource using rsa3 transaction. But I have read the note and it nowhere mentioned the causes of the error. Does the note 998720 will take care of the issue. Please let me know as early as possible. your help in this matter is highly appreciated.



Former Member
0 Kudos

Hi Keith,

You are right its the OSS note, we download and load the data then it works ok no issues.


Former Member
0 Kudos

hey good to have the issues sorted.

think Keith needs some points for the contribution and the post need a closure star

(sorry if you have already done so and it hasnt turned up in the webpage )

Former Member
0 Kudos

Hi Surender,

I'm also seeing the same problem. Did you ever find a solution ?



Former Member
0 Kudos

A suggestion- I am not sure whether this will help.

However I have seen such cases when the data is inputted wrong

If my guess is correct, go to ST22 transaction and see If there is an ABAP DUMP

If you find one- paste the contents of the ABAP DUMP for everyone to analyze, May be we can work out to solve this.

Otherwise, I suggest go and check the CVCs( Time Series) - May be one of them is wrongly inputted like a comma, or some weird character.

Suggest you to delete all the time series( CVCs) and recreate them again.

- Remember to take a backup before you delete the CVCs.

Hope this helps. Good Luck



Former Member
0 Kudos

I did find an ABAP Dump when looking at ST22. The short message is as follows:


Date and Time 05/14/2007 19:33:54

Short text

Jump distance is too large and cannot be generated.

What happened?

A jump distance is too large and cannot be generated.

A control structure or a routine with "CHECK" or "EXIT" contains

too many ABAP statements.

Error in the ABAP Application Program

The current ABAP program "GP_MET_PSTRU_BASIC_FORMS" had to be terminate

because it has

come across a statement that unfortunately cannot be executed.

What can you do?

Note down which actions and inputs caused the error.

To process the problem further, contact you SAP system


Using Transaction ST22 for ABAP Dump Analysis, you can look

at and manage termination messages, and you can also

keep them for a long time.

Error analysis

During the generation of program "GP_MET_PSTRU_BASIC_FORMS", the system

determined that

within an ABAP event a control structure (for example, IF..ENDIF

or LOOP..ENDLOOP) or a routine (for example, FORM routine) has

become too large. The resulting jump distance is too large so that

it could no longer be generated.

With the internal load format, the jump distance must not be

greater than 32768 (this is the size of approximately 10.000

ABAP statements).

The jump distance that is to be generated, however, is 50885.

How to correct the error

The ABAP application program must be changed.

Former Member
0 Kudos

Hello everyone,

In our case the answer to this problem was to import OSS Note 998720.

Thanks, take care.