cancel
Showing results for 
Search instead for 
Did you mean: 

EM-Carrier collboration portal Integration

Former Member
0 Kudos

Hi All,

Have anyone worked with carrier collaboration portal and EM ?

We have a problem that when the events are reported via the CCP we dont see any event messages coming to SAP EM.

How does the CCP work ?

Thanks,

Deb

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Debabrata,

In my opinion, CCP has been integrated with SAP TM not with SAP EM.  So, the updates are coming from CCP to TM and then EM, if relevant events configured in SAP TM to update SAP EM.

Check this good insight documents of SAP TM CCP to give your overview:

ASUG SAP TM document with CCP overview

SAP Transportation Management collaboration portal Overview

Also, if you give us which particular event or scenario is not updated in SAP EM from SAP TM via CCP.

Regards


GGOPII

Former Member
0 Kudos

Hi Gopi,

When I report the events via CCP or directly in TM via the FO, the event type relevance is failing as execution_info_before is equal to execution_info. Refer to the any of the standard event type of the standard event handler type ODT30.

Thus even though events are reported on the FO execution tab, they are not seen in EM.

Any idea ??

Thanks,

Deb

Zenon
Participant
0 Kudos

Hi Deb.

Did you update the config in TM>FO Management>Freight Order>Define FO Types as below?

Regards.

Zenon.

Former Member
0 Kudos

Yes Zenon, it is done as shown in the picture.

I am surprised how come the execution_info_before table is same as execution_info.

That is the reason why the events are not being sent from TM to EM.

Thanks,

Deb

Former Member
0 Kudos

Hi Debabrata,

Is this happening only for this event or any events reporting from TM not updating in SAP EM?

Is this first time SAP TM to SAP EM integrated?

It looks like configuration issue as per my understanding.  Let me know, I will try to check again in other view.

Regards

GGOPII

former_member186607
Active Contributor
0 Kudos

Hi Debabrata,

if you send a new event or update an existing one, normally, of course, there should be a difference between BEFORE_IMAGE and CURRENT_IMAGE of related entry on EXECUTIONINFORMATION node.

Which TM release are you on (which SP)? Are you using standard event codes and standard event relevance functions or custom ones?

Best regards, Daniel

Former Member
0 Kudos

Hi Gopi,

We have custom internal event codes. For now, we have changed the standard event type for only one event.

The only thing we changed in the event type relevance and extractor is the event id.

Thanks,

Deb

Former Member
0 Kudos

Hi Daniel,

We are working on TM 9.1 SP 2.

If I comment the check between "EXECUTION_INFO_BEFORE" & "EXECUTION_INFO", the event is sent to EM.

The problem is not with the way EM in configured. For some reason, even when the event is reported for the first time, there is not difference between the BEFORE and CURRENT image of EXECUTION_INFO.

When the event is reported for the first time, should not the EXECUTION_INFO_BEFORE be blank ?

Thanks,

Deb

Former Member
0 Kudos

Hi Daniel,

Also, we have custom event codes, extractors and relevance checks.

Thanks,

Deb

former_member186607
Active Contributor
0 Kudos

Hi Debabrata,

one more question:

Which Direct Object Agent are you using (IMG Activity 'Maintain Output Management Adapter Settings')? And in which mode (Synchronous/Asynchronous)?

If you have enabled SEND_EM_DATA_FROM_TOR with Synch/Asynch 'Has Uncritical o/p: Process after Commit (background)', you should check that under 'Nodes for Before Image' the sub node EXECUTIONINFORMATION is maintained. If this is not maintained, it could have the effect that the BEFORE IMAGE is not retrieved correctly.

Best regards, Daniel

Former Member
0 Kudos

Thanks Daniel. It fixed the problem. Now, the execution before and current image are behaving the way it should.

But I figured a new problem. The event type was triggered many times. 3 times to be precise.

Do we know why ?

Thanks,

Deb

former_member186607
Active Contributor
0 Kudos

Hi,

so the relevance function is called three times in one transaction?

Best regards, Daniel

Former Member
0 Kudos

Yes Daniel. Because we have reprocessing of expected events as allowed, it does not show on the document. Neither does it on the application log.

Thanks,

Deb

Answers (0)