cancel
Showing results for 
Search instead for 
Did you mean: 

Assembly of GET PLOBJID procedure of Planning Level XYZ failed

vincentverheyen
Active Participant
0 Kudos

Our Planning Area can activate without errors up until assigning a Key Figure to the Planning Level XYZ.

The problem occurs when creating an Attribute, or when assigining an Attribute as Key Figure (to this Planning Level).

The planning area activates fine when deleting this Key Figure.

Already tried all of the steps at https://me.sap.com/notes/0002613551, many thanks for any additional input.

Accepted Solutions (1)

Accepted Solutions (1)

vincentverheyen
Active Participant
0 Kudos

In this case, the solution was that; even if one has double checked that (if the Attribute as Key Figure comes form a Compound Master Data Type which has Key Attributes A, B, C & D) the base planning level of that Key Figure has these same Root Attributes A, B, C & D; one still has to make sure that: for all the remaining attributes assigned to the Planning Level which are key in their corresponding Master Data Types, the attributes must also be root in the Planning Level.

Answers (2)

Answers (2)

mohnotrahul
Participant

Hi Vincent,

Please ensure that the Attribute, you are using for creating attribute as Key Figure must be existing in the Master Data object which has all the root attributes of its planning level.

If system is not able to fetch any of the attribute in the planning level the error GET_PLOBID failure will arise.

-Rahul Mohnot

vincentverheyen
Active Participant
0 Kudos

Hi mohnotrahul, this is the case. Attribute comes form a Compound Master Data Type which has Key Attributes A, B, C & D + Year. The base planning level has these same Root Attributes A, B, C & D + Year. Underlying Master Data also exists.

mohnotrahul
Participant
0 Kudos

Hi Vincent,

Please check now for all the non-root attributes in Planning level and your Compound master. Compound master should have them all.

-Rahul

vincentverheyen
Active Participant
0 Kudos

Hi mohnotrahul is this mentioned as necessary in the configuration guide?