cancel
Showing results for 
Search instead for 
Did you mean: 

SRM - unable to create ECC PO from SRM RFx Response

Former Member
0 Kudos
399

Hi all,

I am on SRM 7.02, Level 5 (SAPK-70205INSRMSRV) using the classic scenario, using bidding in SRM server.

process

  • SC created in SRM - > SC goes to sourcing -> buyer creates RFx -> RFx is sent to bidder -> bidder processes RFx Response -> buyer accepts RFx response -> buyer creates follow on document (PO) from RFx Response (create PO).

problem:  once the buyer clicks "create purchase order" from the Accepted RFx response, the system throws a green checkmark message "Purchase order cannot be created as there are no items" (message number is /SAPSRM/PDO_QTE 069), even though there is 1 line item.  The ECC PO is therefore NOT generated.  since this is the classic scenario, an ECC PO should be created directly.

my set-up

  • I have set up internal number range in SRM (Define Number Ranges for Shopping Carts and Follow-on Documents) PO 4300000000 4399999999
  • I have set up the same number range (external) with separate document type "ZSRM" in ECC
  • I have assigned "ZSRM" order type to attribute DP_PROC_TY in SRM org structure (ppoma_bbp)

Am i missing anything?  what could be causing this error?

cheers,

View Entire Topic
0 Kudos

I am also facing the same  issue

Please provide your inputs, I  checked the number range and transaction types in ECC and SRM everything looks fine ..pls guide

Former Member
0 Kudos

I mentioned above...we debugged it, and found that the SC doc type was defaulted in attribute BSA; after removing default, the PO was able to be replicated.

0 Kudos

Hello Aleem,

Thanks for your reply.

For my case Iam seeing the PO in XML monitor in ECC, the PO struck with some data errors like "Invalid G/L account", "plant is not responsible for purch org", "invalid Purch group".

While creating the auction we cannot give G/L account -- not sure how to over come this.

Other errors like Invalid Pgroup evenn though the Pgroup exists in ECC.

Any inputs please.

Thank you

Regards

Srinivas G

0 Kudos

We have the same message "PO XXXXXXXXXX is in the process of transfer to back-end system", however, the PO is NOT replicated to in any of the systems (SRM or ERP). To attribute BSA indicated one value "NB", the "Default" is not check.

There is no other error, please help.

Former Member
0 Kudos

I think we removed the value of BSA entirely.  After that, it worked for us.  Give that a try.

Former Member
0 Kudos


hi,

We didn't use XML/PI for this scenario, so my scenario is different from yours. 

What SRM version do you have?  Did you create your auction with reference to a Shopping cart?  Does your shopping cart have a GL account assigned to it (indirect / service item), or is it for a stock  (direct) item?  If you are using a direct item, do you have customizing switch SRM_702_DIRECT_MATERIAL activated?

Please double check your ECC org structure to ensure your POrg is responsible for the plant you are using, and also ensure your SRM org structure is correct (Pgroup to POrg assignment, and locations (plants) are assigned correctly).  If they are correct, then get a developer to debug, because in my experience, the error messages returned by SRM are not always correct and can be misleading.

Cheers,

AD

0 Kudos

Removed the value of BSA entirely - did't help


My process: buyer creates RFx -> RFx is sent to bidder -> bidder processes RFx Response -> buyer accepts RFx response -> buyer creates follow on document (PO) from RFx Response (create PO).


If we activate the extended classic scenario, the PO is replicated to both systems (SRM or ERP), еhere is no other error.


In classic scenario we have a problem, PO is NOT replicated to in any of the systems.Today checked SC, if SC manually created in SRM - its replicated to both systems (SRM or ERP) in classic scenario.

0 Kudos

1. We have RFC-connection

2. SRM version - 7.13

3. RFX manually created in SRM, isn't reference to a Shopping cart

4. SRM_702_DIRECT_MATERIAL activated

5. org structure is checked


Regards

former_member208244
Active Participant
0 Kudos

Hi Viachaslau,

You need to populate attributes in your purchaser user in SRM to default account determination and allow creation of POs in Backend without SC.

Regards

SG

0 Kudos

Hi Sebastian


You mean the attribute REQUESTER?


Regards

VG

former_member208244
Active Participant
0 Kudos

Hi,

I mea, the account assignment attributes like default cost centers and etc. As you don't have XMLs and no Direct material you must assign an account assignment, when no SCs in play, then default account details in your PPOMA_BBP position is required.

Regards

SG

0 Kudos

Default account details in PPOMA_BBP there's. I have not filled the attribute REQUESTER, maybe because of this problem?

Regards

VG

former_member208244
Active Participant
0 Kudos

Hi,

REQUESTER is just for shop on behalf.

Please check next points:

Customizing:

Proper Product Category to GL configuration done

User attributes:

Default account assignment category

Default cost object assigned

Kind Regards

SG

0 Kudos

Check

Regards

VG

0 Kudos

on the same topic, how  the G/L will  be fetched is it from the requestor account assignment or froom the product that  used in the bid ?

currently in my case there was a CC default which I removed but now the PO is automatically taking the account assignmet as "P" ( WBS related) .

doo we have any option like forcefully  process the XML in ECC and create the PO in  held status that really helps for our requirement