Showing results for 
Search instead for 
Did you mean: 

Purchase Order with "Error in Process" status????

Former Member
0 Kudos

We are currently using SRM 4.0 in an extended classis setup. We have been live for appropriately 1 yr and half and I have noticed more and more Purchase Orders going into status "Error in Process" when a change (increase value, add line items, change name) has been performed on the PO and then the PO is approved. The PO will sometimes show up in the SRM Administration Tab occassionaly but more than less they don't and we have to search for failed PO to find all the "error in Process" PO's. I have had success with having the user just change something in the name of the PO and then re-order and the PO will then go into R3 but I was wondering is there something in the system other than having the user change the PO that I can do to push the PO into R3. When we have similar issues with confirmation I run tcode SWO1 and use the GUID ID and click transfer to push it to the backend. Is there anything I can do in the backend that will send the PO into R3 and update the status to Ordered giving there is no apparent error in the system?

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hello Robert,

We've been facing a similar issue (we are also in SRM 4.0 Extended Classic Scenario): Sometimes, when the user modifies a purchase order from SRM (for example, to add some new items), the purchase order replication to the backend failed.

In the Application monitor, we had the following backend error:

"Insert Cost Center for Item X"

but the Cost Center value was correct (other items from the same purchase order had the same account assignment).

We thought the problem was related to the function module in the backend which was changing the purchase order, so we put a SAP OSS Note.

In this OSS note, SAP recommended us to implement note 1005615, and the problem was solved.

Check if this note could be implemented in your backend.

Hope this helps you,


Former Member
0 Kudos

Hi Robert,

The issue you are facing is not clear from the info. provided by you. Its difficult to tell what exactly is causing this problem.

Use Application Monitors RZ20 transaction code and SLG1 to get a clear picture about the error and why the P.O is failing during transfer to back end. It can be for any reason. Say for mismatch of number ranges etc..

Please look into these things to get a clear picture about the issue and also update us about the issue to help you further in this regard.

Award points for helpful answers.



Former Member
0 Kudos

Well that is the point. Even when using RZ20 or SLG1 it's not returning a reason why the PO is showing "Error in Process". Again this is not the norm for all "error in process" PO's but we're having alot of PO's with "error in process" without a hint of what the problem is and whenever we make a minor change to the PO and reorder the status will change to ordered after it's approved or if it doesn't need approval it will change to status "ordered" and transfer to the backend.

So when we have PO's that have no noticeable error message we normally have the client change something in the name of the PO so that they can just reprocess the PO. This has worked in several occasionals but I'm trying to determine if there is something I can do in the backend with the clients help to reprocess those PO's to see if they will transfer to R3.