Showing results for 
Search instead for 
Did you mean: 

PO still in Approval Status (Urgent)

Former Member
0 Kudos

Hi All,

I am working on extended classic scenrio.

I ordered a shopping cart which has the status approved and follow on document were created in this case it is a local PO(contract release order)

when I checked the local PO, I found that this PO is in approval state also a copy of this PO exist in the backend system.When I tried to change this PO I get the warning message that "Document is still being processed in the background,try again later".

I tried several times at regaular interval but again it gave the same warning message.

I also checked the two reports clean_reqreq_up and bbp_get_status_2 and I found that some of the entries are missing beacause I created this PO around 2pm and the entries were available in the two report from 10 pm.

I think something might have gone wrong there but I am not having a log of that.

I am on SRM version BBPCRM 4.0 SAPKU40007

R/3 version 4.6 C SAPKH46C47



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Raj,

the message "Document is still being processed in the background,try again later" is raised because your PO is blocked in a Workflow lock.

With the PO GUID, look in table BBP_WFLOCK.

You should find an entry.

From this entry, check the status of the linked tRFC with FM STATUS_OF_BACKGROUNDTASK = f(tid).

You can also check in <b>SM58</b> if you have a transactional RFC hanging on --> you should start with this check.

Your PO can also be blocked by a running WF (you can check it with FM BBP_PDH_WFL_CHECK_WF_BUSY.



PS: please reward points for helpful answers

Former Member
0 Kudos

Hi Cristophe,

I checked the table BBP_WFLOCK and could not find any entry.

However in transactional RFC I could see an entry for this user XXXX and tried to delete this entry but I am not able to do so,below are the details observed in SM58

SWW_WI_EXECUTE_INTERNAL_RFC is the Function module.

WORKFLOW_LOCA is the target system.

Error in the module RSQL accessing the database is the status text.

Also I checked the FM BBP_PDH_WFL_CHECK_WF_BUSY but did not find any error.

One thing I would like to mention is that in BBP_PD the workflow status is completed for the PO but only in the web browser it is showing the status Awaiting Approval.

Again I tried to change the PO but again I received the same warning error "Document is still being processed in the background,try again later".



Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello Raj,

Please check timestamp of the error entry in SM58 and find some information around the error time in ST22 or SM21.

After you fix the source errors, Edit->Execute LUW in SM58.



Answers (0)