Showing results for 
Search instead for 
Did you mean: 

Integrated RFX - Formula's

Former Member
0 Kudos

Hi Guys,

we have an integrated system and are using integrated RFX'es where the Formula Support has been enabled. However, when creating an RFX through Integration Formula's cannot be used; I am getting the following error message on anything that is not a Unit Price Formula:

Error trying to determine formula result type. Operands of incompatible types.

This also happens on simple formula's such as Quantity*UnitPrice(Inco_Term). I don't get it - and this is a major showstopper for the GoLive of the Integration.

Now, through testing I've managed to narrow it down to something to do with the Incoterm, but I cannot work out what it is. The Incoterm that's not working is set as No Location Required - I assumed that that was the problem, however, removing that Incoterm, Saving the RFX, changing the Incoterm in Master Data and then re-adding it did not solve the problem.

Does anyone have any idea what this means and how to fix this?


Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

I get the same error on and off, is this an issue where you try and duplicate an existing event lets say an auction or a RFx and when you validate the formula you get the same error Error trying to determine formula result type. Operands of incompatible types.

If anyone can shed some light on this would be great, thanks Tridip

Former Member
0 Kudos

Hej Tridip,

I ended up opening a SAP Message and then actually creating a new RFX Template - that had solved the issue. Not sure why this happened, but in the SAP Message it said this:

It is imposssible to calculate Price type + Amount type as result type is not resolved from this formula.

Other than that we had an issue with this before my time and this was fixed by the Hosting Team, however that fix might have looked like.

My suggestion is to open a SAP Message and send them the logs.