cancel
Showing results for 
Search instead for 
Did you mean: 

IDOC (BLAORD03) could not be saved..

Former Member
0 Kudos
248

Hello all,

When we create GOA in SRM and after approval.. it is not getting distributed to ECC..

When we debug, RFC Call, in ECC there is no IDOC Generated against to this Contract Number.. And the call in failing with the following discription

IDOC (BLAORD03) could not be saved

Application error in backend system D01CLNT200 (SRM outline agreement 6100000043)

We Implimented BADI's for Condition (Mapping) in SRM and Company code updation (in ECC)..

- IDOC it self is not getting generated in ECC, Partner profile is maintained for message - BLAORD

Pls suggest..!!

Thanks in Advance.!!

Regards,

Mohan Vamsi

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Thanks Sanjeev and Muthu..Problem resolved!!

former_member183819
Active Contributor
0 Kudos

Hi vamsi

What was the issue. How did you resolve.

regards

Muthu

Former Member
0 Kudos

Hello Muthu,

Issue was with Company code, in BE. (I think as, I have to debug it yet..). Which is a mandatory field in particular segment..!! but I was unable to debug and see how is WORKING though I am following external debugging method!!

Pls have your say, Thanks for your help,

Answers (2)

Answers (2)

former_member183819
Active Contributor
0 Kudos

Hi vamsi

I dont know It helps you or not.

se91 S_DX_BAPI 103 IDoc number &1 could not be saved to the database

check program - how it throws error message in bapi load program

regards

Muthu

former_member206968
Active Contributor
0 Kudos

Hi,

Pl. check txn SLG1 in backend system. You might get some vital clues and then proceed. Also check SM58 txn logs in both the systems.

Regards,

Sanjeev

Former Member
0 Kudos

Hello Sanjeev,

Thanks for help, quite useful, but there is not entry available in this transaction for our "Contract Manufacturing" or any Purchase Contract Creation in Back ground..

IDOC itself is not getting generated.. Pls suggest.

Thanks a lot for your help.!!

Regards,

Mohan Vamsi

former_member206968
Active Contributor
0 Kudos

Hi,

In your partner profile, have you defined entries for idoc for conditions posting. I think its COND_A02 or something. Also check authorisations for your rfc user in ECC.Try assigning sap_all to this user.

Regards,

Sanjeev

Former Member
0 Kudos

Hello Sanjeev,

Yes, we maintained partner profiles for both the message types, and, Profile in ECC is SAP_ALL.

Any other places which I need to check.. Pls suggest. Very much thankful for your help.

Also..

Now I hard coded our ECC Sytem LS name in BADI Implimentation of BBP_DETERMINE_LOGSYS as per the documentation.!!

Regards,

Mohan Vamsi..

former_member206968
Active Contributor
0 Kudos

Hi,

For GOA, you don't need a Badi implementation for bbp_determine_logsys.

I would suggest you to closely check partner profile parameters in txn-we20 in ECC or backend system that you use. Check if you have defined both these idocs in the Inbound parameters for the partner profile(LS for SRM system). Also check if all the process codes are correctly assigned for inbound processing.

Regards,

Sanjeev