SAP for Banking Discussions
Join the conversation about navigating compliance, enhancing customer experience, and driving growth in the banking industry with SAP.
cancel
Showing results for 
Search instead for 
Did you mean: 

NW04s ABAP installation failed at phase 11 of 24

Former Member
0 Kudos

The error messages were "The dbmcli call for action ACTIVATE failed. FCO-00011 The step sdb_instance_activate with step key .......... was executed with status ERROR".

When I checked the logfile XCMDOUT.LOG the last 5 lines showed:

OK

ERR

-24988 ERR_SQL: Sql error

3, Database state: OFFLINE

6, Internal errorcode, Errorcode 9050 "disk not accessible"

My interpretation was that the database was started successfully and subsequently stopped. I verified it through manual start up of "SAPDB: NSP" in the "Services". Any help to resolve this proble will be greatly appreciated!

14 REPLIES 14

Former Member
0 Kudos

Hi,

I am trying to install SAP Netweaver 2004s ABAP edition in an XP SP2 machine.

At phase 11 of 24 of the installing process, i get the following error message.

"The dbmcli call for action PARAM_INIT_INST failed"

On checking the log file at XCMDOUT.LOG, i got the following message.

"Error! connection failed to node **** for database NSP:ERR_USRFAIL: User authorisation failed".

I tried unistalling the same thrice but everytime the message is the same.

Can anyone help me out with this.

Thanks in advance.

Sundar R

0 Kudos

I guess you don't have adminstrator rights on the system.

Sarath

0 Kudos

I am trying to install SAP Netweaver 2004s ABAP (SP16).

At phase 11 of 24 of the installing process, i get the following error message.

"The dbmcli call for action PARAM_INIT_INST failed,...."

XCMDOUT.LOG:

Execute Session Command : param_startsession

Execute Session Command : param_init OLTP

Execute Session Command : exit

> Subprocess stops at 20060422061601

OK

ERR

-24976, ERR_PARAMEXIST: param file of database already exists

Any help greatly appreciated.

Babu

0 Kudos

Hi Sarath,

I think these comments won't help. Everybody who want's to install this kind of software has admin rights at the system, otherwhile no one came to this point...

<b>@all other:</b>

I still have the same problem. I tried now more than 10 times to install this bugy type of software (now it's the 2nd day I'm trying...). And this forum isn't that good as it could be, but this depends also on the errors the installation throws for which you can search for. The error-codes are no real codes to search for. Is there nowhere a FAQ with these common question?

At every problem I tried to find a solution in this forum, sometimes after several posts I found some hints, but most hasn't a solution, which is very anoying. I had errors in phase 6, 8, 11, and 17. And the best thing is with the newer j2sdk I came to phase 17, now with j2sdk_1.4.2_08 the error occours at phase 11. And before cleaning the system by hand, it stoped at phase 6.

My problems has been:

- At first I tried to install the MiniSAP 4.6D from the book "ABAP Objects", but this installation stops at that after define the system-folders for the installation-CDs.

- So I tried now to install "SAP NetWeaver 2004s Sneak Preview ABAP" after downloading the 1,6GB SAPNW2004sSneakPreviewABAP.rar.

- After the download I had to create a new user with local admin rights.

- Than I had the problem with the jre / j2sdk. After changing the jre 1.5x back to j2sdk1.4.2_11 back to j2sdk1.4.2_08 and clean the system serveral times by hand, because the uninstell doesn't work aswell. Which means whipe out all files, users and shared folders, cleaning the <i>hosts</i> and <i>services</i> in C:\Windows\system32\drivers\etc\ and so on.

- And now the installation stops at phase 11 of 24.

- The point with the loopback adapter isn't nessesary if you're connected to a network.

Here are the logs:

<b>View Log</b>


<b>INFO 2006-12-28 12:20:01</b>
Execution of preprocess block of 
|NW_ABAP_OneHost|ind|ind|ind|ind|0|0|NW_CreateDB|ind|ind|
ind|ind|9|0|NW_ADA_DB|ind|ind|ind|ind|6|0|SdbPreInstanceDialogs|
ind|ind|ind|ind|2|0|SdbInstanceDialogs|ind|ind|ind|ind|1|
0|SDB_INSTANCE_CREATE|ind|ind|ind|ind|0|0 Step sdb_init_instance_type returns TRUE.
ERROR 2006-12-28 12:20:03
The dbmcli call for action PARAM_INIT_INST failed. Check the logfile XCMDOUT.LOG.
<b>ERROR 2006-12-28 12:20:03</b>
The dbmcli call for action PARAM_INIT_INST failed. Check the logfile XCMDOUT.LOG.
<b>ERROR 2006-12-28 12:20:03</b>
FCO-00011  The step sdb_init_instance_type with step key 
|NW_ABAP_OneHost|ind|ind|ind|ind|0|0|NW_CreateDB|ind|ind|
ind|ind|9|0|NW_ADA_DB|ind|ind|ind|ind|6|0|SdbPreInstanceDialogs|
ind|ind|ind|ind|2|0|SdbInstanceDialogs|ind|ind|ind|ind|1|
0|SDB_INSTANCE_CREATE|ind|ind|ind|ind|0|0|sdb_init_instance_type
 was executed with status ERROR .

<b>XCMDOUT.LOG</b>


--------------------------------------------------------------

> Subprocess starts at 20061228105028

 Execute Command : c:sapdbprogramspgmdbmcli.exe -s dbm_version
 Execute Session Command : exit

> Subprocess stops at 20061228105028

 OK
 VERSION    = 7.6.00
 BUILD      = DBMServer 7.6.00   Build 018-123-113-357
 OS         = WIN32
 INSTROOT   = c:sapdbnspdb
 LOGON      = True
 CODE       = ASCII
 SWAP       = full
 UNICODE    = (unknown)
 INSTANCE   = (unknown)
 SYSNAME    = Windows XP

--------------------------------------------------------------


> Subprocess starts at 20061228105028

 Execute Command : c:sapdbprogramspgmdbmcli.exe -n SYSTEM db_enum
 Execute Session Command : exit

> Subprocess stops at 20061228105028

 OK
 NSP	c:sapdbnspdb                        	7.6.00.18	slow	offline
 NSP	c:sapdbnspdb                        	7.6.00.18	fast	offline

--------------------------------------------------------------


> Subprocess starts at 20061228105029

 Execute Command : c:sapdbprogramspgmdbmcli.exe -n SYSTEM -d NSP -u CONTROL,********
 Execute Session Command : param_startsession
 Execute Session Command : exit

> Subprocess stops at 20061228105029

 Error! Connection failed to node SYSTEM for database NSP: ERR_USRFAIL: User authorization failed

--------------------------------------------------------------

So my final question is, is there anywhere a system which is ready to install on a WinXP SP1 system or can anyone help me...? I won't spend any more time trying to install this...

Thx for every help.

Rossi

0 Kudos

ERR_USRFAIL - reason may be because you have not removed the old AXDB properly.

i would suggest to run the uninstaller of NW2004s first, which would remove all unwanted stuff and try a complete fresh installation.

Regards

Raja

0 Kudos

Now, after trying J2SDK 1.4.2_09 an install the loopback adapter, I won't come further than Step 2 "Define Parameters" -> SAP System > OS User Passwords.

The error-log says:


ERROR 2006-12-28 14:31:34
MDB-07057  The system is inconsistent. Registry or SAP_DBTech information is available, 
but software is not complete.

ERROR 2006-12-28 14:31:34
MUT-03025  Caught ESAPinstException in Modulecall: ESAPinstException: error text undefined.

ERROR 2006-12-28 14:31:34
FCO-00011  The step CheckExistingServerSoftware with step key 
|NW_ABAP_OneHost|ind|ind|ind|ind|0|0|NW_CreateDB|ind|ind|
ind|ind|9|0|NW_ADA_DB|ind|ind|ind|ind|6|0|
Sdb_ServerSoftware_Dialogs|ind|ind|ind|ind|0|0|
CheckExistingServerSoftware was executed with status ERROR .

This is really brilliant stuff, if you like to play the game "How to spend a hole weekend trying to install a really bugy software called SAP NetWeaver"...

I think I'll give up installing this sh..

bye Rossi

0 Kudos

Hi Raja,

thx for answering, but the uninstall break also.

But I'll give it now the last go, after another failure I'll kill this stuff completly.

Do you have any ideas, why the old stuff MiniSAP 4.6D doesn't work on a WinXP SP1 aswell...?

thx Rossi

0 Kudos

Let me share my experience with you

first time ever i installed this minisap was when 6.10 was was available.

after that everytime i want to upgrade, i used the new softwares uninstaller to uninstall stuffs. (if you have deleted MAX DB manually, you have to remove maxdb relevant entries from registry as well)

I too had problems, but they are all mainly due to the fact that the requirements were not followed strictly.

get the system cleaned of all old installations. (if the new installer's uninstallation doesnt work , you may have to manully delete registry entries and the folders created by the old installation).

follow the following steps carefully.

(i assume you are using Windox XP professional)

1. Make sure that the file system of your machine in NTFS

2. give your computer a name (mycomputer->properties) and make sure it dosent have any special characters and not longer than 13 characters.

3. install jdk 1.4.2_08

4. make sure your windows/system32/drivers/etc/services file doesnt have entry for 3201, 3601 and 500 (i dont remember this, just follow the requirements from the installation documentation)

5. install loop back adapter and maintain the tcpip property of this loopback adapter ip to 10.10.0.10 (follow the documentation from the installation documentation)

6. Now start the installation, you should not have any problem at all.

Regards

Raja

0 Kudos

I've uninstalled now the J2SDK-1.4.2_09 and installed the J2SDK-1.4.2_08.

I also deleted all registry entries with maxdb, sapdb and NSP. Then I've deleted all user-entries for SAP and all installed files.

I've installed the loopback adapter and defined the IP with 10.10.0.10 and the submask with 255.255.255.0.

The computername is 10 characters log including only numbers and characters without spaces.

The <b>HOSTS</b> includes 2 lines:

127.0.0.1 localhost

10.10.0.10 SYSTEM0001

The <b>SERVICES</b> doesn't include any entry for Ports 3201, 3601 and 500xx.

The <b>system</b> is:

Fujitsu Siemens Lifebook C Series

1,6 GHz

1GB RAM

30GB HDD (50% free)

WinXP SP1

Are there any problems when using another network (e.g. WLAN for internet) at the same time?

Now I'm gonna start the computer again and try to install it again.

But I've another question: <b>Where can I get a newer version of MiniSAP like mine (it's from 2001)...?</b>

thx Rossi

0 Kudos

That's what i've suggested. It came up in <b>step 2 Define Parameters"

-> SAP System > OS User Passwords</b>.


ERROR 2006-12-28 16:06:32
MDB-07057  The system is inconsistent. Registry or SAP_DBTech information is available, 
but software is not complete.

ERROR 2006-12-28 16:06:32
MUT-03025  Caught ESAPinstException in Modulecall: ESAPinstException: error text undefined.

ERROR 2006-12-28 16:06:32
FCO-00011  The step CheckExistingServerSoftware with step key 
|NW_ABAP_OneHost|ind|ind|ind|ind|0|0|NW_CreateDB|ind|ind|
ind|ind|9|0|NW_ADA_DB|ind|ind|ind|ind|6|0|Sdb_ServerSoftware_Dialogs|
ind|ind|ind|ind|0|0|CheckExistingServerSoftware was executed with status ERROR .

I think I give up now. This is really big sh..., sorry.

cu Rossi

0 Kudos

<i>Are there any problems when using another network (e.g. WLAN for internet) at the same time?</i>

no problem.

new version can be donwloaded from

https://www.sdn.sap.com/irj/sdn/downloaditem?rid=/library/uuid/cfc19866-0401-0010-35b2-dc8158247fb6

Raja

0 Kudos

Hi Raja,

I also downloaded the new SAP NetWeaver 2004s and tried to install this, as you can see above.

I'm asking for a new MiniSAP which is not the NetWeaver.

Yesterday I tried to install also my old MiniSAP, but I didn't come further than installing the MS SQL. The installation broke probably by missing the ODBC.

So I give up, thx for the help.

Rossi

Oliver_S
Product and Topic Expert
Product and Topic Expert
0 Kudos

Well, in some cases the automatic start of MaxDB fails. So start MaxDB manually and continue.

And: Make sure u use j2se 1.4.2_08!!!

Former Member
0 Kudos

i have the same problem of Quang Huynh.

anyone can help me?