cancel
Showing results for 
Search instead for 
Did you mean: 

usage of Graphical Content in forum post?

Ashwin
Active Contributor
0 Kudos

Hello !

why do we not have a provision for using graphical content or attachment in the forum posts. is there any reason behind. some times it is very hard to explain merely in words.

When you are supporting smiley's in the subject why don't they work inside posts?

with regards

ashwin

View Entire Topic
eddy_declercq
Active Contributor
0 Kudos

Hi,

Although I'm also a favourite of the abilty of adding non textual content, I think there is always the issue of supported formats and the size of all this.

Eddy

Ashwin
Active Contributor
0 Kudos

Yes!

but something is better than nothing. what do you say?

with regards

ashwin

maximilian_schaufler
Active Contributor
0 Kudos

The reason why smileys are not supported in the post texts ... I don't see any to not put them in.

But on the other side, I also see no real reason they should be in - after all the majority of discussions in here is technical, so emoticons would not be that suited imo.

If someone wishes to express their emotions, then a simple or will also be understood by others.

As for attachments - it might be that SDN does not want such content spread over all the forums but they like to have it structured in articles, downloads, ... guess that's part of the reason (the other part being development resources not having to be freed for this).

Max

thomas_jung
Developer Advocate
Developer Advocate
0 Kudos

If I remember right Smileys were originally allowed in the current forums (for the first few days after the upgrade). However the reaked havok with the in-line code so they were removed.

Ashwin
Active Contributor
0 Kudos

Hi!

Actually in BW forums we need graphical content like some kind if report structure or when explaining the relations between fields. it sometimes get hard to explain with hard. It would be nice to have such facility in future. It is helpful for better explanation of a problem and hence might not be useful if put in a article or Blog. I hope we get such kind of functionality in future.

And regarding smileys i was just curious to know why they are supported only in subject.

Thank you for your valuable replies.

with regards

ashwin

former_member374
Active Contributor
0 Kudos

Hi Ashwin,

The main reason for not supporting attachments is that we want to keep the forums spiffy

We did some tests with attachments and they drag down system performance. It's really easy to post your screenshot somewhere else on the web and link to it, if plain text is not enough.

Regarding Smilies Thomas' memory is quite good.

Hope that helps, Mark.

former_member188975
Active Contributor
0 Kudos

I agree with you Ashwin...I have wished for this ability several times, esp when you need to explain something like a variable offset. But I guess Mark is right about the performance...I would not be surprised if it leads to stuff on the questioning side too: attaching requirement docs and screen shots of errors instead of typing them

Former Member
0 Kudos

I can understand not wanting to deal with attachments, but when trying to answer some questions, a picture can be worth a thousand words...... or more likely, a picture can avoid 5 followup questions.

Could SDN a provide a graphic host rather than having to use some public host. The graphic content would then be under SDN control and could be restricted just to SDNers.

Former Member
0 Kudos

I just posted a similar question in another forum and was directed to this post.

For technical issues it's sometimes critical to be able to show a picture of what you're talking about. Especially when you have people from all over the world reading/responding to this forum.

I really like this idea of asking SDN to provide a hosting service available only to SDN users.

Can we get an official response from SAP on that?

Former Member
0 Kudos

Hi all,

I can understand that image attachments would drag down the system performance but would it work so that if user attach any image to the post it would appear as a link instead of image?

Regards,

Ville

Former Member
0 Kudos

Pictures (or attachments) should not be dragging system performance down that much, any big forums do provide support for attachments/images.

If the performance is an issue, or the problem that inline code causes trouble with smilies, SAP should <i>_really_</i> consider to rewrite the forum, from scratch.

@Mark, what scenarios are tested? If I look here, the most common need are images (so jpg/gif/png are web standards) and should not be bigger then 40Kb. In my opinion as webdeveloper, that should really not be a problem. (Nor drag down system performance) Note that the avarage SDN page is >100Kb, so some little pictures should not be a problem.

Former Member
0 Kudos

Not sure if you are aware but the forum software is a 3rd party piece of software. Now I was not present when they did the image attachment testing, however from my understanding the results were quite bad.

They are still checking into it and they are still working on it, so perhaps in the future things might change until then we all do what we can.

ryan_wicks
Explorer
0 Kudos

Is it still not possible to post attachments to forums? We are using EP6.0SP15

David
Advisor
Advisor
0 Kudos

Hello Ryan,

This is possible with the software, but we have not activated the functionality due to the security risks inherent in allowing direct uploads from external sources.

Best Regards,

David

ryan_wicks
Explorer
0 Kudos

Hi David,

Thank you for the quick reply. I apologize if I am confused, but isn't the risk the same as allowing users to directly upload files into KM folders - as they are also coming from external sources?

Thanks David!

Ryan

David
Advisor
Advisor
0 Kudos

Hi Ryan,

We don't allow direct upload into the KM either. The process is indirect. We have an external server which hosts the Content Submission application. The items uploaded there are placed within the KM by a designated group of Content Managers after a review process.

Best Regards,

David

ryan_wicks
Explorer
0 Kudos

Hi David,

In my case, we allow direct file uploads into KM - and would like to do the same for forums/discussions. Is there a way that we can activate this feature in the forums? Or is this something that is not possible?

Thanks!

Ryan

David
Advisor
Advisor
0 Kudos

Hello Ryan,

Activating it depends on what software you are using. We use Jive by Confluence. Technically, it arrives out of the box activated. All we have to do is assign the permissions to use it to the various user group levels we have established and people could start immediately. In fact, the functionality is there for moderators such as myself. We have an extra button available in edit mode that says "Attach Files".Like Santa, we know where to go after one of the moderators if they do something bad

Best Regards,

David

ryan_wicks
Explorer
0 Kudos

Hi David,

I see. We are using the standard EP 6.0 'discussion' iviews (from SAP) for our forums. I was thinking there was a way to enable file uploads in these iviews.

Thanks,

Ryan

David
Advisor
Advisor
0 Kudos

Hi Ryan,

I am sure there is a way to do this. This capability existed in the old EP5 version. Try posting this question in one of the Enterprise Portal forums. Also, you could check the on line documentation at http://help.sap.com.

Best Regards,

David