cancel
Showing results for 
Search instead for 
Did you mean: 

HANA Smart Data Access using Cloudera ODBC driver

Former Member
0 Kudos

I'm trying to add an external source using smart data access and the ODBC driver by Cloudera.

I've configured everything:

  • unixODBC installed
  • Cloudera drivers installed (both Impala and Hive)
  • $HOME/.odbc.ini configured
  • $HOME/.customer.sh configured:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/cloudera/hiveodbc/lib/64:/opt/cloudera/impalaodbc/lib/64

export ODBCINI=$HOME/.odbc.ini

  • After login with <sid>adm in the linux console, isql -v <dsn> is successful for both Hive and Impala sources
  • I can create and select tables over isql (linux console)
  • I restarted HANA

However, after configuring the source(s) with HANA Studio I got the following error:

SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: [unixODBC][

  • First of all: is it possible to get the complete message? It seems it is truncated  after the last "["
  • Second: where is the error?

Regards,

Nicola

View Entire Topic
Former Member
0 Kudos

Hi Nicola,

You mentioned setting the LD_LIBRARY_PATH environment variable to include the drivers' lib directories. Did you also set it in the .customer.sh script? According to this post Note 1968653:Smart Data Access - generic odbc - file not found a similar error message is returned by HANA Studio if the LD_LIBRARY_PATH environment variable is not set in the .customer.sh script.

Regards,

Holman

Former Member
0 Kudos

Hi Holman,

in .customer.sh I have:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/cloudera/hiveodbc/lib/64:/opt/cloudera/impalaodbc/lib/64

export ODBCINI=$HOME/.odbc.ini

The error message says:

SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: [unixODBC][

One problem is that this error message is truncated after "[unixODBC][". So I cannot tell you which error actually occur. Is there the possibility to have a complete error message and not a truncated one?

There should be a setting somewhere.

One othe issud could be the use of Cloudera own drivers instead of Progress DataDirect.

Regards,

Nicola

Former Member
0 Kudos

If I use the Progress DataDirect driver I have another error message:

SAP DBTech JDBC: [403]: internal error: Cannot get remote source objects: Could not get tables

HANA version is SP9

Regards,

Nicola

Former Member
0 Kudos

Hi Nicola,

Thanks for the clarification. Judging from the [unixODBC] part in the error message it looks like the error message is coming from the driver manager. Like you have mentioned, the error message is truncated and it's the important part that gets truncated so it's hard to tell what the driver manager is complaining. Unfortunately I am not familiar with HANA Studio so I cannot tell you how to get the full message. I am more familiar with the ODBC driver side.

Regards,

Holman