cancel
Showing results for 
Search instead for 
Did you mean: 

WWI Server Error

Former Member
0 Kudos

In our development environment, I could not generate even the simplest of reports - it kept breaking the WWI RFC connection. Upon reviwing several OSS notes, it became clear that our WWI software was outdated. So we upgraded the software to SP 20. The problem was fixed, and we could run complex templates in the server without any problems.

We upgraded our Quality and Production environments WWI servers software also to SP 20, hoping to get the same results as we were getting in development. No dice! The RFC remains stable and does not break, however I get the dreaded GP (Generation Possible) Status. CG5Z (WWI Monitor shows error and CG50 shows GP status).

I used a template with a single line of text AND NO SYMBOLS to eliminate template syntax errors. Please review the error logs content reproduced below in plain text and see if you experts can spot something obvious:

Date Time Message

12-07-2009 12:04:45 Job started

12-07-2009 12:04:46 Step 001 started (program RC1WWIWP, variant , user ID RSANTHANAGO)

12-07-2009 12:04:46 Problem occurred during report generation; check the report log

12-07-2009 12:04:46 Generation error on WWI server SV001

12-07-2009 12:04:46 Internal program error; (SAPLC1F3 C1F3_GEN_RAWREPORT_CB API_READ 0120)

12-07-2009 12:04:46 Internal program error; (SAPLC1F3 C1F3_GEN_RAWREPORT_CB API_UPDATE 1162)

12-07-2009 12:04:46 Job finished

Using t-code SLG1, object EHRE,

At time T, got GREEN indicator which gave following messages:

Report for spec. 000000302705, variant ZRAWNONFD, language E, status WA is replaced

Report for specification 000000302705, variant ZRAWNONFD, and language E created

At time T+8 seconds got RED indicator which gave following messages:

Error occurred when generating value file; process is canceled (repeated)

Then GREEN indicator with message:

SBR WWI-00000000000000000102

Seems like the Report is geting created then, after a substantial delay of 8 seconds, an error occuring in generating VALUE FILE!!

Any ideas?

Thanks in advance for your help!

Anil

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Anil,

I used to get this error. What i did is re-installed the Gen PC in CGSADM this eliminated the issue, hope it works for your case too, if not please check the following if you didn't,

1) The user under which the WWI generation server service is executed

has the required DCOM start authorization or access authorization

to start MS Word from a service.

Check note: 580607 for further info on this.

2) Check whether a process WinWord.Exe hangs on the WWI server.

Terminate this in the task manager on the WWI server. See Note

788573.

3) Check the printer settings, refer note 788573.

4) MS word may hang with several WWI generation servers running in parallel.

Hope this helps you.

Former Member
0 Kudos

Thanks Ravindra. I forwarded your suggestion to the Basis team and they are investiigaing. I agree with you and am convinced it is some sort of a security issue. I have also asked them to switch my Q box WWI RFC (which does not work) to the WWI Server that DOES work in development. I can't imagine this being a difficult thing since WWI RFCs are TCP/IP connected!

Regards,

Anil

Former Member
0 Kudos

Ravindra, Thank you, thank you, thank you....................

It was a security issue and it is fixed. Hopefully this will help others with similar issues, so here is the fix:

With reference to my original problem above and the log, notice program (service) RC1WWIWP has user ID RSANTHANAGO. In the development WWI where it worked OK, the user ID was of another user with a security profile with higher priviledges. We replaced RSANTHANAGO with this other user and problem is fixed.

Again thanks,

Anil

Answers (0)