cancel
Showing results for 
Search instead for 
Did you mean: 

Work Instruction error. 403 Forbidden SSL required.

sayuj_nair
Explorer
0 Kudos

Hi,

Even Im facing an issue related to the Work Instruction in DM.

All the PRT documents are transfered to DM. But when I click preview, Im getting the error message as 403 Forbidden - SSl required. 

sayuj_nair_0-1708354546469.png

 

Could anyone tell me how can I solve this error. 
I have created the document with cv01n transaction in S4 and the PDF is saved in my local storage. 

KR,
Sayuj.

View Entire Topic
rahul_kumar_04
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi , 

Data is transmitted over a secure connection (https port). To enable data transmission, you must activate the service for structuring and reading a URL for this purpose. To do that, choose transaction SICF, browse for DEFAULT_HOST in the Virtual Host field and choose Execute. Expand default_host  sap  co_mes_int  co_mes_document. Select the service and choose Activate in the Service/Host menu.

More here : https://help.sap.com/docs/sap-digital-manufacturing/integration-guide/configuring-production-order-w...

Hope this helps.

Thanks

Rahul

sayuj_nair
Explorer
0 Kudos

Hi Rahul,

Thanks for your reply. I have already done this setup as seen below. 

sayuj_nair_0-1708620970213.png

Is it something to do with a certification? 

KR,
Sayuj.

rahul_kumar_04
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Sayuj,

The 403 Forbidden error due to access limitation or SSL setup. You may need to check with ICF config , how HTTPs request being handled. Use request tracing tools like httpwatch to analyse further , mostly certificate issue . 

You can perform Quick check on request details

1. Open the developer tool in browser and try to access the WI , keeping the developer tool open .

2. Now open the network tab and check the request details which is specific to WI .

3. Check the request url (complete) and reach out to Network/SAP Basis expert . 

Thanks

Rahul 

sayuj_nair
Explorer
0 Kudos

Hi Rahul,
Hope you are doing good. Thank you for your reply. 
According to your last message I tracked the URL, that was being generated and found the issue. 
The issue is related to the port number. Do you know how can I change the Port number in the URL that was created from S4. 

Please let me know how can I proceed further. Thank you in advance. 

KR,
Sayuj.

rahul_kumar_04
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Sayuj ,

I am not expert in port configuration . 

Usually Port settings are defined in instance profile of system , using RZ10 you can check parameter icm/server_port_xx , in case of no parameter definition , system uses the default port. You need to maintain instance profile for specific port . Hope this helps.

Thanks

Rahul