cancel
Showing results for 
Search instead for 
Did you mean: 

Rights Needed to Execute Transactions

Former Member
0 Kudos
61

When I execute a transaction from the workbench in 12.0 SP3 using a test account, I get the following error:

[ERROR]: Error executing transaction: Could Not Execute Transaction: [TMP6a683fe1-52b8-11dd-a23e-c9339be0c17a] test01 is not assigned to a role that can perform this action.

I assumed the service needed is 'XAcuteRuntime' but the test account is in the 'xMII Users' role and that role is assigned to that service.

Any ideas?

David Macindoe

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi David,

Even we were getting the same error last week when we Migrated from 11.5 to 12.0,

refer to [this Thread|;,

You may need to export the transaction and change the Write access manually to assign the Test Role and import again.

Hope this helps

regards

Rupesh

agentry_src
Active Contributor
0 Kudos

To expand on what Rupesh suggests:

Create a new transaction, save it, then export it. It will show whatever default security roles are assigned. The export your transaction of interest. Look in the same relative location in the file to see what roles are assigned. Manually edit to change to roles which are correct for your system.

Good luck,

Mike

As a side note, you should also upgrade to 12.0.4 which is available.

Edited by: Michael Appleby on Jul 16, 2008 1:58 PM

Former Member
0 Kudos

Quite a few helpful suggestions there. In the transaction I'm testing the Reader Role is associated with 'xMII Users' of which my test account is a member. I exported the transaction, deleted the transaction in the Workbench, then looked in the exported transaction on my desktop. It had:

<Name>Metrics_ING_008/ING008_CA</Name>

<Version>323</Version>

<WriterRoles>XMII Administrators,XMII Developers</WriterRoles>

<ReaderRoles>XMII Users</ReaderRoles>

I deleted XMII Users from the transaction's ReaderRoles and re-typed it. I then re-imported back into the Workbench. It still failed.

When I create a transaction in the Workbench, the default roles are:

<WriterRoles>XMII Administrators,XMII Developers</WriterRoles>

<ReaderRoles>XMII Administrators,XMII Developers,XMII Users</ReaderRoles>

I don't think the issue is in the Reader Role because I can open the transaction in the Workbench OK - I just can't execute it.

jamie_cawley
Advisor
Advisor
0 Kudos

This is a bug in 12.0.3 that was resolved in 12.0.4. The only work around for 12.0.3 is to add the role to the writers roles.

Regards,

Jamie

Former Member
0 Kudos

Jamie - I just stumbled on that solution an hour ago and was just getting ready to post it. It was one of those things where I didn't know why it worked but it did. Your comment of a specific bug fixed in 12.0.4 makes me feel alot better! We'll make plans to move to 12.0.4!

David Macindoe

Answers (3)

Answers (3)

Former Member
0 Kudos

You execute this transaction in some other account except test account.If you are not getting any error, then problem is only in your test account.

Goto User Management and check the user test01,what are the roles are assigned to this user.Administrators,developers and Everyone roles must be assigned to user.

If it is ok, then once you restart the services in your test server.Hope this will help you.

Thanks,

Manisha

Former Member
0 Kudos

Hi, David Macindoe

if i were u, i would do the following to find out what exactly the problem is:

1.... i will change another account to test this transaction, like xmii_developer or admin, to see whether or not i will also get the error msg. if not, then it could be something associates with the user account. and then i can check the reader role /writer role configuration.

2....if u also get the same error msg after changing a user account, i think that would be something assiciates with the system security settings.

i hope that will help u .

jcgood25
Active Contributor
0 Kudos

The error is probably coming from the Transaction Security ReaderRoles/WriterRoles. How does this line up with the Roles assigned to your test user?

Regards,

Jeremy