cancel
Showing results for 
Search instead for 
Did you mean: 

PPM5 MS Project Integration

wolfgang_brunneder
Participant
0 Kudos

Hi experts,

I've a problem configuring the MS Project integration for project management in order to export a project in ms project format. For that purpose I've installed sapcryptolib. Unfortunately, when I try to export to MS Project I receive as error message "MSProject: This path is not in the security list". However I've configured and installed the whitelist using tcode WDR_ACF_WLIST. The generated certificate is located at C:\Documents and Settings\...\Application Data\SAP.

Whitelist:


  <?xml version="1.0" encoding="utf-8" ?> 
- <frontendServices version="7.0.0.0">
- <execute>
  <extension>mpp</extension> 
- <application path="C:\Program Files\Microsoft Office\OFFICE11\WINPROJ.EXE">
- <parameter position="01" type="STRING">
  <legalValue>*.mpp</legalValue> 
  </parameter>
  </application>
  </execute>
  </frontendServices>

Does anyone have an advice to fix this problem?

Many thanks in advance!

Kind Regards

Wolfgang

View Entire Topic
FA1
Active Participant
0 Kudos

Hi,

you have to specify all directories / paths which are allowed for importing or exporting files,

please see an (shortened) example below.

Kind regards,

Florian

<?xml version="1.0" encoding="utf-8" ?>

- <SAP>

<type>SAP object rules</type>

<version>1.0</version>

<timestamp>24.11.2011 18:36:00</timestamp>

- <configuration>

<rule_set_priority>0</rule_set_priority>

</configuration>

- <rules>

- <rule id="1">

- <file_extensions>

<name>*.mpp</name>

</file_extensions>

<enabled>1</enabled>

<action>0</action>

</rule>

- <rule id="2">

- <file>

<name>C:\Program Files\Microsoft Office\OFFICE11\WINPROJ.EXE</name>

</file>

<enabled>1</enabled>

<action>0</action>

</rule>

- <rule id="3">

- <directories>

<name>C:\Temp</name>

<permission>r</permission>

</directories>

- <directories>

<name>C:\Temp</name>

<permission>w</permission>

</directories>

<enabled>1</enabled>

<action>0</action>

</rule>

</rules>

- <systems>

- <system type="2">

</system>

- <system type="3">

</system>

</systems>

</SAP>

wolfgang_brunneder
Participant
0 Kudos

Hi Florian,

thanks for your replay. I configured the whitelist according to your proposal. Unfortunately, the error message remains the same!

Is it possible that the problem is due to a wrong sapcryptolib installation? I have installed the files in the relevant directories on the application server and set the profile parameter sec/libsapsecu, ssf/ssfapi_lib and ssf/name. Is there a possibility to check the sapcryptolib installation?

Kind regards

Wolfgang

Former Member
0 Kudos

Wolfgang

Drop me an email I can send you a document on what I configured and it works - spent ages on this issue and finally got it right

wayne.messervyatgmail.com

Regards

Wayne

Former Member
0 Kudos

Hey,

I was able to solve this issue.

Following are the steps that I have done to solve above issue

1. Configure whitelist: T Code = WDR_ACF_WLIST

2. Generate Certificate: T code = WDR_ACF_GEN_CERT

3. Distribute/ Install Certificate on user computer: ACF_WHITELIST_SETUP

In the first step where you add directory for upload and download, make sure you add directory to which user has access to. So in my case, my system was on domain, I had to use administrator login where I found that it is access issue. Then I configured directory which I had access (for example : C:\users\mahk\SAP). I did not get this error thereafter

Regards

Mahendra