cancel
Showing results for 
Search instead for 
Did you mean: 

MDO issue in SAP MII 12.2SP03

Former Member
0 Kudos

Hi,

We are facing a length problem in Persistant MDO in MII 12.2SP03. Here, we generate a guid which is 36char .But the MDO table can't insert the parameter with 36char, it gives the following error:


[Details :com.sap.sql.log.OpenSQLException: Failed to set the parameter 1 of the statement >>INSERT INTO MDO4551
 (FIELD1,FIELD2,FIELD3,FIELD4,FIELD5,FIELD6,FIELD7,FIELD8,FIELD9,FIELD10,FIELD11,LASTQUERYEXECUTION,LASTQUERYEXECUTIONBY)
 VALUES(?,?,?,?,?,?,?,?,?,?,?,?,?)<<: Cannot assign a >>java.lang.String<< 
object of length 36 to a parameter with JDBC type >>VARCHAR(13)<<] 

In the MDO,this field is already assigned with varchar(40).

Infact, it also can't insert more than 6char string value.

It was all okey in the 12.2SP02. Is it a problem of new patch?

We have tried to solve the problem but unfortunately we couldn't find any solution.

If any one can plz help us out in any other ways it would be very helpful.

Thanks & Regards,

Ritwika.

Edited by: Michael Appleby on Feb 8, 2012 1:41 PM used to display error message better.

Accepted Solutions (0)

Answers (2)

Answers (2)

former_member193328
Active Participant
0 Kudos

Hi Ritwika

What DB is there behind the MII that the MDO is getting created to?

Please note that with MII 12.2 SP03 the way MDOs worked in the background has been changed a lot.

Starting MII 12.2 SP03 MDOs are no longer created in the DB you would have mentioned in the Custom Data Source. The MDO tables are now created in the NW schema.

I would suggest you take a look at the following SAP Notes.

[1577170|https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1577170]

[1664486|https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1664486] -- Check this one carefully as this note has a package to restore MDOs. May be this will help.

[1664479|https://websmp230.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1664479]

Additionally I would suggest 2 things

1. Upgrade to the latest MII 12.2 SP03 Patch level.

2. Export all your MDOs. Re-import them in a separate project and check if they work.

Regards

Partha

Edited by: Partha Sarathi Roy Chowdhury on Feb 8, 2012 3:43 PM

Former Member
0 Kudos

Thanks for your suggestion.

Now, it is working fine after upgradation to the latest MII 12.2 SP03 Patch level but after that we had to export, delete and re-import the MDOs.

Thanks and regards,

Ritwika

former_member193328
Active Participant
0 Kudos

Hi Ritwika

Good to know that your issue is solved. Please provide points accordingly to the responses.

Regards

Partha

agentry_src
Active Contributor
0 Kudos

Hi Rtiwika,

I think it would be best if you opened a CSS ticket. Please provide the ticket number so I can take a look at it.

Regards,

Mike