Showing results for 
Search instead for 
Did you mean: 

EHS- Inconsistent WWI Report behaviour for different users

Former Member
0 Kudos

Hi Experts,

Several users are experiencing two related problems with WWI report outputs. That is, the two issues seem to be affecting the same users.

1) in transaction CG02BD - menu item Specification>Reports>Report Management - When the user opens a released report, they are
immediately in Edit mode, Word menu options are not greyed out. The report should not be able to be edited.
2) in transaction CG02BD - menu item Specification>Reports>Report from template for a specification which is not in Released status - The report has conditional formatting to display a draft watermark on it if the spec status is not Released, but the watermark is not visible to the affected users, although they can manually add the watermark using the Word functionality after the report is generated.

What could be causing these issues? (We are using Print Layout view).  I have observed that when one affected user logged onto SAP on my computer (my computer does not have the problem I am reporting), the report docs open as display only, as expected, and have a watermark if they are in draft format.  It looks like they are using the same wwi templates on their c drive, and have the same Word Option settings as me.  We tried network profile regeneration with this user, but this had no effect.

One difference I noticed in Word Advanced settings when I run a WWI report, the file Image Size & Quality refers to file Rehsfil0, whereas the affected user had extension rtf (ie Reshfil0.rtf). Does this have any significance?

Any advice or suggestions for further testing would be gratefully appreciated

Sarah Campbell

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Thank you all for your interest in this query, we have resolved the issue.

The Fix:

Essentially it involves re-writing a small part of the computers registry.   The changes point the WWIDOCUMENT to the correct version of Office.

Delete the following Registry keys on the individual user's PC:




Then re-register MS Word, reinstall WWI, open Word and make sure the Trust Center Settings include the WWI directory for the templates in Trusted Locations

Why does the problem occur:

The SAP WWI component is very particular with the order of events.   It must be installed after Office is installed.   If Office is upgraded on the laptop the keys associated with WWIDOCUMENT must also be updated, or the SAP WWI component must be re-installed. 


Active Contributor
0 Kudos

Dear Sarah

thanks for sharing information how you have removed the topic. Only as a hint (😞

If you check this document:

You will find this nice comment as part of the discussion on the content of the document

Just to throw in my two cents worth. With regards to installing Windows services for the EHS Expert Server and WWI Server: one needs a pretty good knowledge about Windows administration as well (service administration, windows policies, event log etc.). So, you probably need an admin guy that takes you by the hand and guides you through the whole installation procedure.

I would assume that you can add now similar additional comments based on what you have learned in the context of WWI set up (and how it is done properly).


Answers (3)

Answers (3)

Active Contributor
0 Kudos

Dear Sarah

only small add on: the most critical issue in using EHS to make sure that an client and any WWI gen sevrer does have the same WWI set up with the same WinWord etc. etc. etc. This is a challenge for the IT department of your company;

If you check document "WWI for experts" you will finda lot of similar threads


PS: it is "very" common that you will get such effects after WWI set up (new WWI version); sometimes the process to distribute the WWI to teh clients is not "100%" robust

PPS: please check hint of Mark !!

0 Kudos

Hi Sarah, how did you implement the conditional output for the watermark? I can remember having done that a few years ago but I can't remember HOW I did it... I think it had something to do with placing the anchor for the watermark inside the conditional output but under Windows 2010 I don't see the anchor anymore...

Kind regards, Michael

Former Member
0 Kudos

Hi Michael

we used the following to set up the watermark in the document header section

<11BRG350(EXIT,APPL_SCOPE;*)><15BIF349(AND:01GEAS_SOS LK"ZRE")><15CIF349><20INCLUDE("WATERMARK",00,SBV)><15EIF349><11ERG350>

However we have since resolved this issue, and I will post a general response with the solution.

Kind regards,


Active Contributor
0 Kudos

Hi Sarah,

The WWI.ini contains (normally in your WWI Folder - for example "C:\Program Files (x86)\SAP\FrontEnd\SAPgui\wwi")

The following section where you can define the edit behavior:


; configurable protection and attached Word template (dot) for

; "display report", "edit report", "report from template" and

; "label preview".


; Possible values for protection:

; 0 = allow edit (no protection)

; 1 = allow only comments (default, does not update page counts properly)

; 2 = allow form fields (does not allow "edit"-"find" and scrolling by PgUp, PgDown)

; 3 = allow only revisions


; The Report...Dot entries define which Word template is getting attached.

; The default is

; "none" defines that no template gets attached


; The Report...Macro entries optionally defines a macro in this template to be started

; before the document is getting protected


; The Report...UsePassword entries optionally define to set a password to disable protection

















Please check and compare the WWI.ini with the WWI.ini where the editing is allowed  and check if thery are set up the same way.

Other issues might be with the local WWI Versions between the two PCs.