cancel
Showing results for 
Search instead for 
Did you mean: 

External candidate registration not happening

Former Member
0 Kudos
234

Dear All,

I'm facing a unique issue regarding external candidate registration. It was working perfectly some days ago registration, e-mail verification going to external candidate, after clicking that url they can create their profile also. After filling all required data if you click register button nothing is happening, but if you give any old user id or e-mail id then its showing already assigned; specify another one.

Our registration & start page is already live and lots of candidate had registered themselves. But now suddenly the registration url is not working.

My start page is working fine, already registered candidate can login by that logon page.

Some screenshot attached here for better reference.

Please help me to sort it out.

Best Regards,

Deeapk

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hello Deepak,

Check the permissions for the user RCF_UNREGSER and validate that have SAP_RCF_UNREGISTERED_CANDIDATE , also check that this user is not a candidate that mean not have a NB relation.

Check the note 1705176


Regards

Jose

Former Member
0 Kudos

Hello Jose,

The user RCF_UNREGSER has assigned the role SAP_RCF_UNREGISTERED_CANDIDATE. The user dosen't have any NB(Requisition) relation. But user has NA relationship, see the below screenshot:

Please guide me.

Best Regards,

Deepak

Former Member
0 Kudos

Hello Deepak..

Sorry... not NB... my mistake...  Should be "not have a NA (Candidate) relation".

  1. Try with a new user with no NA... (Standard SAP USER- with unreg roles)
  2. Delete the relation using program RFC_DELETE_USER (Dont remenber the exactly name of the report but... has those words). Be aware because colud delete also the user.... anyway that user sholud not be a candidate.

Regards

Jose

Former Member
0 Kudos

Hello Jose,

Thanks for the reply. my problem got resolved. It was related to authorization of RCF_UNREGSER.

Some changes also done in coding for data privacy statement issue.

Best Regards,

Deepak

romanweise
Active Contributor
0 Kudos

Hello Deepak,

I think I experienced something like that some time ago in a landscape where the customer used the separated frontend and backend server for e-Recruiting. The issue was a problem with the user creation on the backend. It was either a problem with the RFC or with the authorization (execute function group via RFC), not fully sure as it was some time ago.

For a more detailed analysis I recommend to check the application log (SLG1) on the e-Recruiting system (on both systems if separated frontend and backend server). Furthermore check the system log SM21 that would show if there is any RFC access issue and activate the authorization log in ST01 for the service user.

Kind Regards

Roman 

Former Member
0 Kudos

Hi Roman,

Many thanks for the reply.

In SLG1 I'm not getting any log, but in SM21 I'm getting this. Please see the attached screenshot.

Please tell what to do with this log.

Best Regards,

Deepak

romanweise
Active Contributor
0 Kudos

Hello Deepak,

the log entry points to a short dump. Could you provide the details of this from ST22?

Kind Regards

Roman

Former Member
0 Kudos

Hello Roman,

Please find the attached details of this from ST22.

Best Regards,

Deepak

romanweise
Active Contributor
0 Kudos

Hello Deepak,

have done any changes to the standard hrrcf_c_register_ui component? I see some mime object probably for the data privacy statement there which the service user rcf_unregser does not have the authority to access. I am also unsure about the VW_PDF view which is called.

Have you already run the authorization check in ST01 for the service user?

Kind Regrads

Roman

Former Member
0 Kudos

Dear Roman,

Yes, we have changes the content of data privacy statement as per company policy. So that external candidate can see this data privacy statement before registration.

I have not run the authorization check in ST01 for the service user. Through which parameter and how to execute this authorization check?

One more thing, when i am clicking on data privacy statement i'm gatting the below error:


how to resolve this?

Best regards,

Deepak.

Former Member
0 Kudos

Hello Roman,

As you said that about the VW_PDF view which is called, its happening only when we are clicking on data privacy statement tab. This data privacy statement issue has been resolved then also I'm unable to register.

Let me explain again,


After filling all the required entries in registration page, when we are clicking register button nothing is happening and same registration page is displaying. It means its not executing and no any NA,CP,BP object is creating. Why its happening please tell me?


Best Regards,

Deepak

Former Member
0 Kudos

Hi Roman,

Thanks for the reply, my problem got resolved. It was related to authorization of RCF_UNREGSER.

Some changes also done in coding for data privacy statement issue.

Best Regards,

Deepak