Showing results for 
Search instead for 
Did you mean: 

SSM10 Drilldown issue/problem(selecting whole dimension,not just result)

Former Member
0 Kudos

Hi there anybody , i'm facing some issues with the drill option in the "Scorecard" tab ,would be very grateful if you could help with this.

I have a kpi dimensioned by 6 dimensions (this KPI created in cube builder), 5 dimensions assigned from cube builder (the maximum) and one added by a PAS procedure using SET VARIABLE.

When selecting the drill option ,when you focus on a dimension assigned in cube builder,everything works fine starting the drill from the dimension result(total) as seen in the next image:

But, when you select to focus on the dimension assigned from the PAS procedure,the drill fails to work, showing not the result(total) level of the dimension(i'm not checking the checkbox that lets you show superior levels), but all the dimension members(from input to result), and having problems to drill up and do a drill-down/drill-up process, as can be seen in the next image:

Checking the generated execution log and comparing with a KPI working fine, i discovered the next beheavior:

Before executing the "" procedure(the one showing the selected information based on the focus dimension) with the instruction, EXE '', there are "SELECT DIMENSIONNAME TOTAL" commands and a "FOCUS ON DIMENSIONNAME" command for every dimension assigned to the KPI in cube builder  ,for example, these  2 lines taken from the log:

set con $SelectDim0 "SELECT CLASE TOTAL_CLASE"


But when you select to focus on the dimension not assigned in cube builder, there is the "FOCUS ON ..." command, but there is no "SELECT DIMENSIONNAME TOTAL" command for the focused dimension!! Here you can see the generated log for a dimension working fine, and the dimension with the problem:

Please, if anybody can help me or give me some advice, i will be very thankfull.

Greetings from Guatemala!

NOTE: i found another problem with the drills and another problem in which you select the scorecard for a kpi in one context, but SSM searches for data dimensioned by the dimensions in the cube asigned to another context, i'll post it and it´s solution(related to the  existence of the lastdate document in PAS) as soon as i can.

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Luis,

How are you?

It´s seems to be a standard SSM problem on how the code is executed on the background application.

Have you ever tried to create the 6 dimensions for your KPI directly into PAS?

Probably this hibrid model (PAS and Cube Builder) is been broken while executed.

I hope this help you.


Bruno Heissler

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Luis

Cube builder is a usefull tool when you have small models, but in your case, you've to set the additional dimensions manually (pas code  instructions) and then you have solved your issue