cancel
Showing results for 
Search instead for 
Did you mean: 

"Invalid User ID" error while running OSoft Application in browser

Former Member
0 Kudos

Hi,

I have installed BPC 7.5 SP04 in Multi Server environment where SQL Server, OLAP Server, Reporting Server on one machine and Application Server and Web Server on other machine, After installing I tried to run Osoft application via url "http://Application Server name/OSoft" as suggested in Install guide but receiving "Invalid User ID" error

Error Information

Server Error in '/OSoft' Application.

-


Invalid UserID

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Exception: Invalid UserID

Please guide me on this as what can be the cause of this error and how to fix it.

I have used Windows Server 2008 with IIS 7.

Thanks,

Rohit

Edited by: Khatak Rohit on Mar 18, 2011 10:57 AM

Accepted Solutions (0)

Answers (3)

Answers (3)

sorin_radulescu
Employee
Employee
0 Kudos

That,s means the installation was not really succeed or some from prerequisite software was not installed.

For Example Compatibility with IIS6.5 or Windows authentication and Basic Authentication was not enable from Web server (speaking about Windows 2008).

Regards

Sorin radulescu

Former Member
0 Kudos

Hi Sorin,

After Installation I saw the message saying Installation is successfully completed, can you please guide me on how should I proceed further to fix this issue, we are using IIS 7.0, Does uninstalling BPC and IIS component and reinstalling again would be an option.

Thanks & Regards,

Rohit

sorin_radulescu
Employee
Employee
0 Kudos

First login must be done with Installation user.

In your case you tried to login from your PC where you were conected with your user.

This user is used to connect to BPC and this user has no rights into BPC.

It was used this user because BPC allow Windows authentication.

So you have to go into IE - Tools - Internet Options

Select Security Tab - Select Intranet

Push Custom Level

Go to section - User Authentication - select "Prompt always user and pwd"

Close IE

Open again and try http://nameofserver/osoft you will receive now a prompt for user and pwd.

Input an user and pwd with access to BPC and you will see this time the page will be load correct.

Regards

Sorin Radulescu

Former Member
0 Kudos

Hi Sorin,

Thanks for your reply, I am facing the above problem on Application server itself where I have logged in via Remote desktop with domain admin ID and also this same ID is used to Install BPC on Application server and I have also checked that this Account ID has been there in AppServer Database tblAppsetAccess table.

When I type "http://ApplicationServerName/oSoft on Application server it prompts for Username/Password and I Input same Domain ID which we have used for installation but still recieve "Invalid User ID" error.

Thanks,

Rohit

Former Member
0 Kudos

Hi Rohit

You need to give access to the users to the application set using the BPC Admin console. You can use the account in which you are running BPC under to log into the admin console. For example: On the application server log inot the admin console and grant access to the users who need access to BPC.

Hope this helps

Kind Regards

Daniel

Former Member
0 Kudos

Hi Daniel,

Thanks for your reply, I am not able to see the admin console page even one time after installation, As After Installation when we tried accessing application via ""http://ApplicationServerName/oSoft on Application server it prompts for Username/Password and I Input same Domain ID which we have used for installation but still recieve "Invalid User ID" error.

Thanks,

Rohit