cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Data Upload BPC 10.1 NW in UJFS

Former Member
0 Kudos
1,002

Hello,

Our R/3 system generates 4 txt files, which should be sended to our BPC 10.1 system.

In our case we’re putting this 4 files on a ftp server, and then use the standard method:

To send this files to the “…\Datamanager\datafiles…”, that are visible from the packages of BPC to upload this information to our system.

In Excel with de Data Preview option:

We can see the information is uploaded OK:

But, we’ve defined a package, which is using this file to upload this information to our dimension “CLIENTS”:

Which use that Script:

PROMPT(MESSAGE,"Importar DM Client")

'PROMPT(INFILES,,"Import file:",)

'PROMPT(TRANSFORMATION,%TRANSFORMATION%,"Transformation file:",,,Import.xls)

'PROMPT(DIMENSIONNAME,%DIMNAME%,"Dimension name:",,,%DIMS%,0)

'PROMPT(RADIOBUTTON,%WRITEMODE%,"Write Mode",2,{"Overwrite Hierarchy","Update Hierarchy"},{"1","2"})

INFO(%TEMPNO1%,%INCREASENO%)

INFO(%TEMPNO2%,%INCREASENO%)

INFO(%DIMNAME_DATEFROM%,)

INFO(%DIMNAME_KEYDATE%,)

TASK(/CPMB/MASTER_CONVERT,OUTPUTNO,%TEMPNO1%)

TASK(/CPMB/MASTER_CONVERT,FORMULA_FILE_NO,%TEMPNO2%)

TASK(/CPMB/MASTER_CONVERT,TRANSFORMATIONFILEPATH,\ROOT\WEBFOLDERS\PEF_DES\PEF\DATAMANAGER\TRANSFORMATIONFILES\DM\TF_DM_Client.xls)

TASK(/CPMB/MASTER_CONVERT,SUSER,%USER%)

TASK(/CPMB/MASTER_CONVERT,SAPPSET,%APPSET%)

TASK(/CPMB/MASTER_CONVERT,SAPP,%APP%)

TASK(/CPMB/MASTER_CONVERT,FILE,\ROOT\WEBFOLDERS\PEF_DES\PEF\DATAMANAGER\DATAFILES\DM\DIM_CLIENTS.TXT)

TASK(/CPMB/MASTER_CONVERT,DIMNAME,CLIENT)

TASK(/CPMB/MASTER_CONVERT,KEYDATE,%DIMNAME_KEYDATE%)

TASK(/CPMB/MASTER_LOAD,INPUTNO,%TEMPNO1%)

TASK(/CPMB/MASTER_LOAD,FORMULA_FILE_NO,%TEMPNO2%)

TASK(/CPMB/MASTER_LOAD,DIMNAME,CLIENT)

TASK(/CPMB/MASTER_LOAD,WRITEMODE,2)

TASK(/CPMB/MASTER_LOAD,DATEFROM,%DIMNAME_DATEFROM%)

TASK(/CPMB/MASTER_LOAD,KEYDATE,%DIMNAME_KEYDATE%)

When we execute the package, we get that error:

If we upload the file manually via the option:

In data preview we can see this information ok, like before:

But in that case, the package is processed OK:

We try to find some notes on SAP Support with the text returned by the error:

“Cannot find generated document content in DB Table”

And find the note:

1374116 – Error: “Cannot find generate document in table” when running IMPORT package in BPC Data Manager.

This note is talking about two ways to upload the file:

  • Upload data file by eData-> Update file (recommended). This is the option we use to upload file manually???. Because we would like to automate the process, we can’t upload the file manually every day.
  • Upload the file by UJFS, to be noted, at this time, must right click ‘Upload document for DM’ to upload data file in DM format to server.

We download the file from the ftp server to our computer and try this option:

The file is uploaded successfully. In data preview option, we can see the information OK:

When we execute the package, it works ok.

As we said, we would like to automate the process, so this option it is not valid for us. Is there a valid way to do it without user intervention?.


Thanks In advance.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

We find a solution to our problem.

Our upload process is using now the method "PUT_DOCUMENT_FTP_DATA_MGR" instead the "PUT_DOCUMENT_FTP" method.

With this method the file is uploaded OK and can be used by our packages without error.

Thanks to all!

Answers (5)

Answers (5)

Former Member
0 Kudos

not responding Andy Xu

Former Member
0 Kudos

how transformation file with time flat with example

Entry :

Output in BW BPC :

Why script transformation file transaction in SAP BPC.

thanks

Former Member
0 Kudos

read MVAL keyword for transformation fiel, open a new thread if you have more questions.

former_member211812
Participant
0 Kudos

Hi Experts

I am also facing the same issue, When i validate the file it is throwing an error "Cannot find the generated document  content in the DB Table"

former_member200327
Active Contributor
0 Kudos

You provided a lot of information, but you didn't show what error message you got when you tried running MD Import from FTP uploaded file. Can you please provide that log?

Additionally, I'd suggest comparing records in UJF_DOC* files for document that you uploaded manually and the one that your program uploaded. Can you find any difference besides the time stamp and doc name?

Former Member
0 Kudos

Hello Gersh,

This is the error message in the package execution import of master data:

In the UJF_DOC table, differences are shown when the program is done loading, and when the data load is executed by Excel, this is the screenshot of the load program:

This is the screenshot of the load Excel data:

As you can see there are differences in some areas.

Thanks,

former_member186338
Active Contributor
0 Kudos

Ups, screenshots are hard to read

Former Member
0 Kudos

Hi Vadim,

Attached images:




Regards,

former_member200327
Active Contributor
0 Kudos

Can you please compare records in table UJF_DOCTREE?

Also, have you seen method PUT_DOCUMENT_FTP used in any of the delivered BPC code?

Former Member
0 Kudos

Hi Emilio,

Have you tried to debug the UJFS upload document for DM? and see how SAP is doing it?

I think there must be a table that keeps track of all the uploaded document, maybe you just missing a step with your PUT_DOCUMENT_FTP to update the table.

Andy

former_member186338
Active Contributor
0 Kudos

First you have to download generated file to the desktop and perform byte compare with the working file! Data preview will not show possible differences!

Second - instead of text files you may fill some tables with the required data and on the BPC side use custom logic badi to read the mentioned tables and update master data. You may try to even launch data extraction to the tables from this badi...

Vadim