cancel
Showing results for 
Search instead for 
Did you mean: 

Problems creating a scheduled package

Former Member
0 Kudos

Hi guys,

I have strange issue, which I can't seem to find anywhere else, so I'm struggling to find the answer. There isn't even a SAP Note for it!

I want to run the Admin_Optimise package on a schedule, during the night, and have never experienced a problem with this before. However, this time when I enter the "daily, 3.30AM, etc." details, and click finish I get this error message:

"[RunQueryToServer][CreateSchedule] Error occurred while creating a scheduling Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)"

I've never seen this problem before, and judging by the results from Google, neither has anyone else!!

I have checked all the COM+ components, to make sure the domain account they are using is correct, and have restarted the scheduler-specific one for good measure. No luck.

We have scheduled packages running perfectly in other appsets on the same server, only this one is causing a problem.

We are running BPC75MS SP8, on Windows 2008 Datacentre, with a SQL Server 2008 R2 database.

Please let me know if you can think of anything, because I'm stumped!

Many thanks,

Jason

Accepted Solutions (1)

Accepted Solutions (1)

former_member186498
Active Contributor
0 Kudos

Hi Jason,

the issue seems related with user or psw disabled, strange that only this scheduled package has the issue, try thess notes please

http://service.sap.com/sap/support/notes/1679973

Note 1657680 - How to update user password in Report Manager

maybe these help.

If not useful try deleting the record from bpc schedule and verify also that it's deleted in the windows scheduler and after try to reschedule it.

Check also the tblServerDefaults to see that name specified for 'SchedulerServer' is just the name and not the fully domain name server.

Kind regards

     Roberto

Former Member
0 Kudos

Hi Roberto,

I already tried 1679973, with no luck.

I followed through the steps in 1657680, but when I try to get onto the ReportServer webpage, it says my account "does not have the required permissions". But I'm logged on with the BPC install user, that is in the local admin group.

Maybe this is the problem? How would I go about verifying these permissions? It definitely isn't a UAC problem, as this has been disabled.

I'm not sure how this doesn't work - everything worked correctly when it was installed (I tested it myself).

Any suggestions?

Thanks for your help!

Jason

former_member186498
Active Contributor
0 Kudos

Hi Jason,

if you're using one of the 3 bpc install user what you reported seems an issue with Reporting services, are you sure that the rest works fine?

Check first server diagnostic to see if all it's working fine (if you have installed also in management console)

I will ask your BASIS to check if the Reporting server is ok, it could be user not more valid

See please

http://msdn.microsoft.com/en-us/library/bb934490.aspx

http://msdn.microsoft.com/en-us/library/aa337324.aspx

Also if you have a NLB this could cause issues if it not have right settings, if you have NLB see please http://service.sap.com/sap/support/notes/1602397.

Kind regards

     Roberto

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Jason,

Pease refer note 1657680.

Reason and Prerequisites

When resetting the User COM+ password, Server Manager does not update the password of the OSoftDataSource and OSoftDataSourceAudit in the appset and the application in Report Manager.

Solution

An administrator must manually update the password of the OSoftDataSource and
OSoftDataSourceAudit.

    1. In the address bar of the Web browser, type the Report Manager URL. (You
    can define a URL for the application in Report Services     Configuration
    Manager (Start > Programs > Microsoft SQL Server 2005 or 2008 >
    Configuration Tools > Reporting Services Configuration Manager)

    2. Click the appset name or application name.

    3. Click OSoftDataSource > Change Password, then click Apply.

    4. Click OsoftDataSourceAudit > Change Password, then click Apply.

Regards,

Kalyan.

Former Member
0 Kudos

Hi Kalyan,

Thanks for your reply, but it didn't quite work as planned - please see my reply to Roberto (above)... maybe you can shine some light on this problem?

Thanks again, much appreciated!
Jason

Former Member
0 Kudos

Hi Jason,

Please try using the user ID with which the server was installed.

Regards,

Kalyan.

Former Member
0 Kudos

Thanks Kalyan, but I was already logged on with that user (I always do, if I'm carrying out "admin" tasks).

Thanks anyway!

former_member229290
Participant
0 Kudos

Hi Jason,

The Note 1679973( - Error scheduling packages through data manager ) describes a similar issue.

Could you try it please?

Regards,

Noura

Former Member
0 Kudos

Thanks Noura,

Tried that one too - the Local Security Policy is set as specified. It didn't help with my problem.

Thanks anyway!