cancel
Showing results for 
Search instead for 
Did you mean: 

Importing data error: SIGNEDDATA conversion error

Former Member
0 Kudos

The complete description is:

The number of failing rows exceeds the maximum specified. (Microsoft Data Transformation Services (DTS) Data Pump (8004202c): TransformCopy 'DTSTransformation__13' conversion error: General conversion failure on column pair 1 (source column 'SIGNEDDATA' (DBTYPE_STR), destination column 'SIGNEDDATA' (DBTYPE_NUMERIC)).)

We are trying to convert a value that come with miles separators, use the character "." (point) as separator and "," (comma) as decimal separator, we use a vb function (replace) to change the points for null string, but it doesn't work. Do you have any suggestion to solve this?

We are using BPC 7.0 MS SP3.

Thanks in advance,

Mariana Rodriguez.

Edited by: Mariana Rodriguez on Mar 23, 2011 4:15 PM

Accepted Solutions (0)

Answers (1)

Answers (1)

sorin_radulescu
Employee
Employee
0 Kudos

You just have to specify this into transformation file who is the separator for columns. I'm not sure what you tried to do but it doesn't seems you did it right. (That VB replace). The error is seems is coming from there.

Regards

Sorin Radulescu

Former Member
0 Kudos

Thanks Sorin, I'm sure I didn't explain as well as I can.

We have two files, one is the transformation file and the other is the conversion file, the only field that we need to convert is the format of the Amount filed:

Amount field (in the flat file) comes in the following format: h1. "2.896.357,45-"

when we validate the transformation file we have h1. "2.896.357.45-"

but we need h1. "-2896357.45"

.

There is a way to resolve this issue using formula field in the conversion file?

I tried a lot of ways but none works.

Thanks in advance,

Mariana Rodríguez.

Former Member
0 Kudos

Hi Mariana,

I've had the same kind of problem, which gave me the

General conversion failure on column pair 1 (source column 'SIGNEDDATA' (DBTYPE_STR), destination column 'SIGNEDDATA' (DBTYPE_NUMERIC)).)

errror message

My issue was resolved by changing the CREDITNEGATIVE=NO option to CREDITNEGATIVE=YES, because BPC probably converted negative values as 'string' values in stead of 'numeric' when importing SAP FI data with the minus sign '-' at the end (100-) instead of SQL signeddata (-100)

But I have to be carefull, my Account Dimension setup is as follows:

Balance Sheet Asset => AccType=AST

Balance Sheet Liabilities => AccType=LEQ

Profit and Loss Revenues => AccType =INC

Profit and Loss Expenses => AccType=INC

My flat file seperator is a comma (,) and decimalpoint is a point (.)

We are using BPC 7.5 MS SP07 Patch 02 and I'm not using any VBA to convert the amount.

Maybe it can help?

Regards,

Peter van Drunen - FPM Solutions