cancel
Showing results for 
Search instead for 
Did you mean: 

IF_UJ_CUSTOM_LOGIC~EXECUTE not writing back data

former_member230374
Participant
0 Kudos

Hi,

I am using this method to read data from a model with INPUT and writing after some calculations into INPUT_YTD audit trail.

The logic use to work in Dev and QA but they give me the error message shown in the below screenshot.

I am just passing the final table to CT_D_DATA parameter, not sure if there is any setting etc. why this does not work....any pointers please help

Security and Auth are all looking OK. but still does not know what is missing

Kind Regards

Krishna

View Entire Topic
former_member196060
Contributor
0 Kudos

Please check whether you switched on parameter ENABLE_NATIVE_HANA_MODEL. If yes, switch it off together with ENABLE_HANA_MDX.
If issue still remains, please refer to KBA 2054093.

former_member230374
Participant
0 Kudos

Hi Vadim,

I implemented YTD to Periodic conversion via BADI, I implemented

IF_UJ_CUSTOM_LOGIC~EXECUTE

Sometimes it works fine but for some runs it gives UJO_READ:  An exception has occurred

I tried via UJKT and Data manager package as well. Not sure if this is due to any SP level or any Parameter setting etc.

Pls help. We are on BPC 10.0 (Not on HANA)

Kind Regards

Krishna

former_member186338
Active Contributor
0 Kudos

You have to debug your ABAP badi code! The issue is inside the code...

former_member230374
Participant
0 Kudos

Hi Vadim,

I debugged the BADI logic

when I do WRITE = ON

I get the following  UJO_WRITE_BACK:Cannot perform read

It works fine and passes the correct data into the BADI last statement CT_DATA, then it goes into standard code and it gives the error message.

Please help.

Kind regards

Krishna

former_member186338
Active Contributor
0 Kudos

Sorry, but how I can help without looking on the code and debugging results? Using some magic ?

"standard code" - what do you mean?

Former Member
0 Kudos

Hi Krishna,

It says 0 record queries out.

paste your code here.

Andy

former_member230374
Participant
0 Kudos

Hi Vadim,

By standard code I meant, it finishes the badi method processing and control moves into standard code.

hi Andy

Attached file has the code for your reference

Many Thanks

former_member186338
Active Contributor
0 Kudos

Terrible code created using copy/paste... I recommend you to find a qualified abaper.

former_member230374
Participant
0 Kudos

Hi Vadim

OK but still this does the job in hand to change audit trail etc. and passes the end result into CT_DATA correctly, then when the BADI is executed, it gives the error message. Is there anything we are missing. Any pointers etc. would really help.

Kind Regards

former_member186338
Active Contributor
0 Kudos

"passes the end result into CT_DATA correctly" - I don't think so

And the only thing that can be done - completely rewrite this code!

former_member230374
Participant
0 Kudos

Hi Vadim

if the Per to YTD is run for 6 months, I can see all the right values while debugging in the final table.

That is passed into CT_DATA.

We can take the approach of re-writing using UJ* classes etc. but is there any pointer why the cannot write back to cube...it happens intermittently ..sometimes it writes..sometimes it does not...

Not having a clue why...

Regards

Krishna

former_member186338
Active Contributor
0 Kudos

Just some values are not right Incorrect member ID's or...

I can't help without debug.

And the code is so bad that nothing to discuss....

Former Member
0 Kudos

Hi Krishna,

This BADI will never run in your model as the dimension in the code differs to your model.

thats why it gives an error.

like Vadim suggested, get an abaper.

The code is terrible, use uj objects, not rsdri objects.

ie. uj0_t_sel and not rsdri_t_range

Andy

former_member230374
Participant
0 Kudos

OK Many Thank you for your inputs.

Kind regards

Krishna