cancel
Showing results for 
Search instead for 
Did you mean: 

Error in BUILD pas Model - No database found- Cubebuilder

Former Member
0 Kudos


Hi all,

I am working on SSM 10.1 SP 3.

I creating a model in cube builder and after creating dimension and measure sets, when I click on BUILD PAS MODEL, it is giving me below error.

LSS>
LSS> set control LINKID SSM_CB_EA
LSS>
LSS> .... capture cube id in a control var to simplify queries on other tables
LSS> access lslink
LSLink> connect SSM_CB_EA
LSLink>
LSLink> SELECT CONVERT(VARCHAR, ID) AS CID FROM CPMS_CB_CUBES WHERE NAME = 'SSM1'
[Sybase][ODBC Driver][Adaptive Server Enterprise]CPMS_CB_CUBES not found. Specify owner.objectname or use sp_help to check whether the object exists (sp_help may produce lots of output).

SQLSTATE: 42000
SQL System code: 208


LSLink> lss create code = 'set control CUBEID ' + CID
LSLink> output proc setcubeid;PIPADMINDEFAULT over
LSLink> peek create nohead nonumb
No Fields currently Selected

ACC004:
No Record Has Been Accessed From the Database.
ACC004:
No Record Has Been Accessed From the Database.
CHE FRE
CHE UPD

Please help

Thanks and regards

Rahul Sharma

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Rahul,

Make sure the SSM_CB_EA was created using the Netwevear table owner: sap<SID>db.

Former Member
0 Kudos

Hi Isabel,

Thanks for Response!!

I have Created LINK ID "SSM_CB_EA" with Sybase databse.

Attached is link id credentials.

Please help to resolve the issue!!

Thanks and regards

Rahul Sharma

0 Kudos

Hi Rahul,

Could you please check if there is a database user "sapepddb" existing in the Sybase database?

Regards,

Alicia

Former Member
0 Kudos

Hi Alicia,

Thanks for response!!

This user is already available.

LINK ID is also showing successful while Testing.

Thanks and regards

Rahul Sharma

0 Kudos

Hi Mr. Sharma,

The linked SSM_CB_EA should be created with the database userid who is the owner of the "cpms_*" tables. For most of the databases (eg. MS SQL, MaxDB, DB6), the owner of these tables is "sap<SID>db", but I am not sure if it is the same for Sybase database.

I think this information can be found if you have the access to Sybase database. Suggested you to work with the colleague who are familiar with Sybase database or the colleague who installed NW Java to figure out which database userid is the owner of those "CPMS_" tables.

Regards,

Alicia

Former Member
0 Kudos

Hi Alicia,

I checked and "SAPSA" is the userid which is there and LINK ID is also showing connection successful.

But I still not able to BUILD PAS model.

Please suggest

Thanks and regards

Rahul Sharma

0 Kudos

Hi Sharma,

The owner of "cpms_" tables is required. It's a specific db user, and it's definitely not any existing db user which can replace with this particular user.

Regards,

Alicia

0 Kudos

Hi Sharma,

Please use the db user  SAPSR3DB (all in capital) to create the linkID and try it again.

Thank you very much,

Alicia

Answers (0)