cancel
Showing results for 
Search instead for 
Did you mean: 

Error configuration PCMFIMwebService

Former Member
0 Kudos
107

Hi experts

As you know when you try to create PCM data store  you need to enter the URL WEB SERVER so i'am trying to configurate it following the PCM install guide , i follow all the steps but when i try to open Http://localhost/FIMService/FIM.asmx  i'am getting this error

when i looked arounf for solutions the suggest i found is to enable 32 bit and i did it but i still get the same error .


Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

I use a user from the administrator groupe to create the data store usine Entreprise authentification .

IPS                        4.1 SP4

DATASERVICES   4.2 SP4

FIM&PCM              10

i'am using Socket mechanism of communication

i guess my problem is in the IIS that i don't really understand .

when I remove the IIS and install it again i couldn't find the FIMService under the default website but i can fin the PCM folder . so i add a new website and i create the PCMFIMappPool but still can't open the FIM.asmx

Former Member
0 Kudos

Hi Anas,

You have to run again through the PCM Configuration Wizard to put back the FIMService application in IIS. Don't create you own apps & apppools.

Former Member
0 Kudos

Ok i will try to run the things from the beggining

And thank you alot Mr Baeyens for your help and precious time

Former Member
0 Kudos

Here is the log for this error

=== Pre-bind state information ===

LOG: User = WIN-QO1ENSVDQBI\Administrator

LOG: DisplayName = PCMFIMWebService

(Partial)

WRN: Partial binding information was supplied for an assembly:

WRN: Assembly Name: PCMFIMWebService | Domain ID: 4

WRN: A partial bind occurs when only part of the assembly display name is provided.

WRN: This might result in the binder loading an incorrect assembly.

WRN: It is recommended to provide a fully specified textual identity for the assembly,

WRN: that consists of the simple name, version, culture, and public key token.

WRN: See whitepaper http://go.microsoft.com/fwlink/?LinkId=109270 for more information and common solutions to this issue.

LOG: Appbase = file:///C:/Program Files (x86)/SAP BusinessObjects/PCM/WebServices/FIMWebService/

LOG: Initial PrivatePath = C:\Program Files (x86)\SAP BusinessObjects\PCM\WebServices\FIMWebService\bin

Calling assembly : (Unknown).

===

LOG: This bind starts in default load context.

LOG: Using application configuration file: C:\Program Files (x86)\SAP BusinessObjects\PCM\WebServices\FIMWebService\web.config

LOG: Using host configuration file: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet.config

LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.

LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).

LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/Temporary ASP.NET Files/fimservice/aee62b71/a6134892/PCMFIMWebService.DLL.

LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/Temporary ASP.NET Files/fimservice/aee62b71/a6134892/PCMFIMWebService/PCMFIMWebService.DLL.

LOG: Attempting download of new URL file:///C:/Program Files (x86)/SAP BusinessObjects/PCM/WebServices/FIMWebService/bin/PCMFIMWebService.DLL.

ERR: Failed to complete setup of assembly (hr = 0x8007000b). Probing terminated.

Former Member
0 Kudos

Hi Anas,

Did you check and run through both FIM & PCM installation guides?
In FIM help documentation there is a supplement for PCM:

See here: http://help.sap.com/businessobject/product_guides/FIM10/en/fi_10_pcm_en.pdf

Can you please check for the correct url (and port) in your Internet Information Services (IIS) Manager.

Then use the fully qualified domain name in FIM.


For example: http://yourpcmservername.mycorpdns:1080/FIMService

Former Member
0 Kudos

Hi Jef

Thanks for your reply , in fact i followed the two install guide and i still get this error

so i thought maybe is a problem in IIS i remove it and install it again and this time i get a blank page .

when i try to create a data store in FIM i get the error PCM/FIM: Error “Failed while calling the 'Profitability and Cost Management (PCM)' system to perform...  so i applied all the note but i can't solve it .

Former Member
0 Kudos

Hi Anas, which kind of user and authentication mechanism are you using in the FIM datastore?

Did you try this yet with the sa (SQL server admin account).

Can you check the windows event manager for any authentication issues for the web service?

p.s. can you mention the exact versions of Data Services, FIM, BI/IPS platform and PCM?