cancel
Showing results for 
Search instead for 
Did you mean: 

BPC 4.2 Dimension not saved

Former Member
0 Kudos
170

Hello dear friends,

I 'm encoutering a prroblem when trying to process a dimension in bpc version 4.2

when i click on the process button i have this message

CANNOT SAVE THIS WORKBOOK

ERROR: DIMENSION.XLS EXCEL FILE WAS NOT SAVED

ERROR: DOCUMENT NOT SAVED

i tried to go to manage dimensions screen and save my dimension again

i saved the application using this dimension again

i saved on my desktop the xls file and tried to save it manually on the server but can't save it

please can you help me regarding this issue, how can i solve it without creating a new dimension etc...

thanks in advance

best regards

C.L

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Claire,

I usually encounter that error when I have a separate excel file, opened at the same time I'm gonna process the dimension, with the same file name as the dimension I'm going to process. If that's the case, close the file with the same filename as your dimension name. Also check security whether you have appropriate rights to process the dimension.

Hope this helps,

MVS

Former Member
0 Kudos

thanks a lot for your reply sir,

actually i don't have any other sheet with the same name opened, i only have the dimension sheet opened but i can try by any mean, it won't save it on the server thus not process it

Answers (2)

Answers (2)

sorin_radulescu
Employee
Employee
0 Kudos

Hi Claire,

Usually this is a problem related to IIS configurations or it is a problem related to security of webfolder.

Do you have the file server into same server with application server?

If not then please use Connect As (for virtual folder with your appset) and insert installation user and the password instead of user authentication.

Check if this solve your problem.

Do you have this problem also for apshell or just for your appset?

Also I suggest to put everyone with full control for webfolders (propagate this to all childrens) to see if this problem is related to security of webfolders. Try again to see if this solve the problem.

If any of these two suggestions don't solve the problem then you have to do a backup of your default web site and reinstall the IIS. After reinstall restore your default website and check again.

Every test has to be done using the connection wizard to take the new changes.

Regards

Sorin Radulescu

Former Member
0 Kudos

thank you for your reply, i will try this solution , i'm unable to try it right now but will check and let you know,

apparently i don't have any security problem nor file location problem, i have the rights needed on adminapp file and my dimension files are also located on the server containing the application

currently, the only solution i found effective is to create my dimension , try to process it

once it fails i go to AdminApp folder then delete the dimension file then select any other dimension which has been successfully saved, i do a save as , and then go to process again, and so far it is working fine doing like this, the only requirement is to do a save as on a file with the same dimension type as my dimension and which is working fine

i will update you once i'll be able to check your given solutions

thanks once again

best regards

C.L

Former Member
0 Kudos

The member sheet itself might be corrupted. Rename the suspect sheet to dimension_old.xls and then copy and paste its contents into a new workbook. Don't forget to rename the worksheet tabs.

Also, this is old OutlookSoft KB article:

Please check the following:

Make sure the AdminApp directory is not set to read-only. If it is and cannot be changed you can recreate the directory and move everything over to the new folder.

Delete the files under the AdminApp/LogFiles folder.

Try validating and processing again.

This can also be caused by load balancing software running. We have an issue with load balancing that is under investigation right now. If you have two or more webservers with load balancing you will get these messages periodically. At this time, we recommend using only 1 web server.

Another Osoft KB:

Please try the following on the Everest Server to resolve this issue.</p>

Turn off "enable authoring" on the default web site in IIS on the Everest Server, this forces Everest to use WEBDAV instead of FrontPage Server Extensions which we have found to be more stable. NOTE: IF YOU ARE USING WINDOWS 2003 SERVER YOU WILL FIND THIS UNDER "WEB SERVICE EXTENSTIONS."

Delete all vticnf folders on the Everest Server and in IIS. These folders are a result of using Frontpage Server Extensions rather than WEBDAV.

Enable Content Expiration in IIS:

Under the Default Web Site folder, navigate to the Application Set folder.

Expand the AppSet then right click on the Adminapp folder and select Properties.

On the HTTP Headers tab select the Enable Content Expiration check box and select the Expire Immediately radio button.

Click Apply then click OK.

Repeat for all Application Sets under the Default Web Site.

Run the server diagnostic utility on the Everest Server and check results. It is possible that some of the directories in IIS are not set for "WRITE" access.

Former Member
0 Kudos

Hello,

first of all thanks for your kind help

even if my problem is still not solved, i learnt a lot about bpc parameters reading and trying your solutions

but i have checked all the configuration and everything is perfectly fine, and the server diagnostic doesn't show any problem

so my issue remains and another thing i have noticed about these diemsnions that don't want to be saved

it always happened to me with a user defined type dimension

plus, once i get this message, it becomes impossible to even delete the dimension from "manage dimensions" screen while a normal dimension is easily and successfully deleted throught the same process

in short, once i get this mesage, the dimension is out of service, and i can't do anything with it, not even delete it