cancel
Showing results for 
Search instead for 
Did you mean: 

BCM - CDT Error

Former Member
0 Kudos

Hello, everyone,

We use SAP BCM version 7.0.9.0 in our company, with which we and our employees make phone calls.
However, 4-5 times a day the connection to the CDT breaks off and the BCM "freezes" at the colleagues and they then have to restart the CDT.

Here is a section of a log where this error occurred.

08:24:54.797 (05404 ) ERR> AUDIO[VOL] SystemMixerManager::ReOpen => Unable to open mixers!!!
09:27:01.279 (03340/CEMProxy ) ERR> CEM[IN] Connection to CEM lost!!
09:28:07.719 (06464/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06464/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06460/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06464/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06460/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06456/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06456/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:07.719 (06464/IpcWorker ) ERR> SNET[IN] Incoming channel message to channel, that is not available, ignoring
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] Control::GetValue (Name = 'Lautstärke', ControlID = 4, Channels = 1, Error 6:)
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] Control::GetValue Error Str: MMSYSERR_NODRIVER
09:28:08.929 (06288/PhoneImpl ) ERR> PHONE[run] VOLUME MICROPHONE level get error -> Invalidate microphone volume controller
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] MIC SystemMixerManager::OpenMixers => mixerGetID(0, 0, 20000000) = 'MMSYSERR_BADDEVICEID'
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] MIC SystemMixerManager::OpenMixers => Recording Mixer opening failed.. Error = MMSYSERR_BADDEVICEID
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] SPKR SystemMixerManager::OpenMixers => [OUT] mixerGetID(0, 0, 10000000) = 'MMSYSERR_BADDEVICEID'
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] SPKR SystemMixerManager::OpenMixers => Playback Mixer opening failed.. Error = 'MMSYSERR_BADDEVICEID'
09:28:08.929 (06288/PhoneImpl ) ERR> AUDIO[VOL] SystemMixerManager::ReOpen => Unable to open mixers!!!
09:28:36.496 (06464/IpcWorker ) ERR> CEM[IN] Connection to CEM lost!!
09:30:20.628 (06288/PhoneImpl ) ERR> PHONE[run] heartbeat has not been answered - closing
09:35:08.262 (05404 ) ALW> Set safety exit to 10 seconds
09:35:08.262 (06240/WatchdogThread) ALW> Watchdog: Application instance stopped


The Windows Firewall was deactivated via GPO
As an anti-virus solution we use Panda
We use Plantronics DA40 and DA70 headsets

Thank you

Peter Graefen

Accepted Solutions (0)

Answers (5)

Answers (5)

sebastian_tur
Explorer
0 Kudos

Hi guys,

Did you manage to solve this issue? We start to have the same problem now. It seems to be problem rather with workstation but no clue whats could it be.

BR,

Sebastian

wayne_fillipaeoh
Explorer
0 Kudos

Hi Guys,

Just started experiencing the same issue on rls 7.0.8 ie11. Being running it for the last years with no issues. We have an integration with CRM (IC_agent). We been having endless issues with CRM freezing/lagging during interactions. This happens sporadically for different agents. We have the same setup in a different locations all working fine as well - using the same instances.

During troubleshooting of the current lagging within CRM the network team changed the routing to see if it resolves the CRM LAG. During this routing changes we started experiencing the CDT issue described above.

Call scenario is as follows.

Agent on an active incoming call - No Issues

Agent tries to conference another party - call does not seems to be establishing on the CDT and while holding to see the outcome of this second call(conference) , the original incoming call drops and the agent seems to have no speech path.

Through monitor I checked the recording and could hear that the conference call took place as the party being called(2nd leg conference) answered and speech path active.

The agent was unable to hear the conferenced party.

Could someone please confirm if this matches there scenario?

former_member637989
Discoverer
0 Kudos

Hi,

Did you manage to solve this issue? I am having the same problem now, but is only happening in one location. The rest of lacations are working correctly.

Thanks and regards

former_member411556
Discoverer
0 Kudos

Hi Sergio,

no, unfortunately the issue is still there. BTW: we're on version 7.0.12.0 and are using WIN10 laptops with IE11. Never had this issue before when using WIN7 desktops (also with IE11).


Best regards,

Mark.

0 Kudos

Ouuuu, the dreadful experience of being forced to use IE, our client also happens sporadically.

WIN 10, desktops with IE11.

Probably the problem comes out there, I hope to solve it ASAP, we go out in production in hours ......

Tnks, bst regrds.

Sergio.

former_member411556
Discoverer
0 Kudos

Hi Peter,

we're currently experiencing exactly the same issue. Did you ever find a solution for this issue?

Thank you,

Mark Blok

0 Kudos

Hi Mark,

you could solve this issue, I have exactly the same problem in the CDT's stations.

Thank you.

Sergio Saavedra.