Showing results for 
Search instead for 
Did you mean: 

XL Reporter Problem

Former Member
0 Kudos

Dear Experts,

I need your favor in solving a problem of XL Reporter.

In our one of PC there was Windows XP and Office 2010 which we have upgraded later on to Windows 7 x64 and Office 2010 (same version as it was earlier). After this upgrade the user is not able to run XL Reporter. If i run it from Administrator account, it runs perfectly, but while i try to run it I am unable to run it.

To run XL Reporter we need to configure Excel from user account by making him Administrator by adding COM Add - in. SAP Business One add on is already added and XL Reporter need to be added. While i add it nothing happens. Later on after some search on internet I have found that we need to register a registry file,

C:\Program Files (x86)\SAP\SAP Business One\AddOns\XLR\XLReporter\ComAddIn_per_User_RegKey.

I got a message that it registered successfully. After this process I could see iLytix XL Reporter has been added to Excel COM Add - in module, which shows the same location as IXXLReporter.dll (i think both are same and referring the same file).

Following this process while I run XL Reporter, i get a message in Excel ...

An error occurred during the process "Report Initialize".

Description: (666) Error! Unable to get document!

Type: 22

Cause: Application-defined or object-defined error

XL Reporter startup failed.

By pressing OK button it starts Excel with report format and headings, but no data is available. While i close Excel it shows another message

Run-time error '91':

Object variable or With block variable not set

By referring various websites and blogs I've come to know that XL Reporter requires .NET 1.1 and 2.0 but this might not be problem as it runs fine in Administrator log-in.


The user is member of Administrators Group

Under Windows 2008 R2 Domain.

Windows 7 64bit

Office 2010

The user has been given full rights on C:\, SAP Folder, MS Office Folder, Registry.

Tested on 2 different systems, but appears same problem.

Possible reason that i could imagine is about rights but I don't know where it lacks.

Any suggestion on this would be highly appreciated.


Dhaval Vadher

Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor
0 Kudos


Please refer SAP note:

- XLR - Unable to run or edit reports with .NET 2.0 installed

Thanks & Regards,


Former Member
0 Kudos

Thanks for the reply.

The link asks for authentication.

From my username and password it is not getting accessed.



Active Contributor
0 Kudos


To access above note, you need valid S-user ID and password.

Thanks & Regards,