cancel
Showing results for 
Search instead for 
Did you mean: 

XL Reporter error

Former Member
0 Kudos

Hi All,

I have a problem at the time of running excel reporter.

"Security settings in Microsoft Excel prohibit XL Reporter from running."

I am using SAP B1 2007B Patch 04

Regards

Shashi

Edited by: shashi mantripragada on Nov 2, 2008 10:50 AM

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

In addition to Note 853821, please follow the steps below (slightly different to steps

in the note):

1) Open Excel

Tools-> Macro-> Security-> Trusted Publishers tab

On the Trusted Publishers tab:

-> Untick Trust all installed add-ins and templates.

-> Tick Trust access to Visual Basic Project

2) Close Excel

3) Open Excel

-> You should have a security warning 'contains macros' by

Microsoft Corporation

Tick-> Always trust macros from this publisher

and

click-> Enable Macros

4)Open from Excel

Tools-> Macro-> Security-> Trusted Publishers tab

and

Tick -> Trust all installed add-ins and templates

Please go back in again to make sure that the settings take effect as

sometimes they do not.

Also in the macro security use the security level Low or Medium.

At the same time check the attached note 853343.

Regards,

Abhinav Banerjee

SAP Business One Forums Team

Edited by: Abhinav Banerjee on Nov 22, 2008 2:45 AM

Answers (2)

Answers (2)

Former Member
0 Kudos

Please check SAP notes 924561 to see if you can find any solutions.

Thanks,

Gordon

Former Member
0 Kudos

Hi,

this for 2003 XL

1. open a new Microsoft XL Worksheet.

2. Then Click on Office Button (u can find that at top left corner)

3. then one menu will populate. (it consists New, Open, Save .. etc)

4. at the bottom of the menu u can find the Excel Options button. Click on the Excel Options.

5. Then one window will populate. then select Trust Center which is on Left side of the window

6. Now u can find the Trust Center Settings.., click that one.

7. On Right hand side, In Macro Settings, select 3rd one. that is Disable all macros except digitally signed macros

8. Below that, In Developer Macro Settings, select Trust access to the VBA project object model

You try this for 20007 XL..

Start MS Excel -> Tools -> Macro -> Security Tab -> choose Low or Medium click ok

second thing invoke to Trusted Publisher Tab -> there are two check boxes -> checked Both

click ok

and try..

I think this may help you..

Regds,

Samapth Kumar Devunuri.

Former Member
0 Kudos

Hi

Thanks for the reply

Actually I am using MS office 2007. But I dont see any Tools option in the menu bar...

Well what I can see is

Home, Insert Page Layout, Formulas, Data, Review View Add-Ins

Thanks & Regards

Shashi

Former Member
0 Kudos

In Excel 2007, Macro Security in under 'Developer' on the Toolbar.

By default, you cannot see 'Developer'

Press F1, type in 'Developer tab', there is steps you can follow to display it.

Former Member
0 Kudos

Hi I tried by pressing F1 But it is showing help screen...

Is there any option?

Can you give me information in detail?

Regards

Shashi