cancel
Showing results for 
Search instead for 
Did you mean: 

When previewed, the document do not print the same

former_member303406
Participant
0 Kudos
1,518

Hi everybody,

one of my customers have a problem that drives me nut. It is regarding documents printed by B1 plain. When the document is previewed before being printed, it prints OK. But if printed "directly", using the printer icon or Document Print, then we have problems like:

- a field moves down or characters are bigger so one field partially hide another one

- fileld with is reduced, and contents print on two lines

One of the users there told me"I always preview before printing, because otherwise it does not work right, Isn't that normal ?"

I noticed one thing: when document is previewed before being printed, the name of the document is the name of the PLD format. But it is printed directly, it is, for A/R Invoices, INV20010, this name depends on the patch level.

Thanks

Gilles Plante

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

hello,

the behaviour you describe is ususally related to the fact that fields are set to autoheight. Maybe Note 1258427 might help you

avoid the behaviour reported?

Kind regards,

sonja

former_member303406
Participant
0 Kudos

Sonja,

thanks for your input. Part of our problem was caused by the feature that lets you reduce the size of the fonts for the preview: everything is fine in the preview, but when you print, you are in for surprises !

The problem that remains is with a field in the repeatable area. For some reasons on particular printers, the font gets bigger than on some other printers, up to a point that the field need another line to print everything. The result is not very nice.

Gilles Plante

Former Member
0 Kudos

Hi Gilles,

if you have not already done so, I would recommend that you would log a message for support.

If, as you report this is concerning one particular field in the repetitive area, I believe we should investigate it on support side. As you confirmed that neither Note 1059781 nor Note 1258427 apply in your case, we should have a look at the 'affected' field in detail.

Is the current field overlapping/placed on top of any other field? What are the settings of the field in the format tab? What is the difference to the other fields?

Have you tried to 'recreate' this field and checked if the behaviour is the same? What I mean with this is, set the current field that cause the issue to 'not visible' (general Tab: untick visible ; Left = 0 / Width = 0 / Top = 0 / Height = 0) and create the field new.

Kind regards,

Sonja

former_member303406
Participant
0 Kudos

Sonja,

a message with support has been created. But since one of the printers that has the problem is a multi-function printer, a Xerox WorkCenter, and B1 does not support multi-function printers (any of them), the problem was kind of pushed back to me. I was told to reproduce the problem in our test environment - we are a B1 reseller.

Thanks

Gilles Plante

Former Member
0 Kudos

Hi Gilles,

I had a brief look at the attachment on your message to support. To me it looks that you have this issue because you have the tick set for 'Previewing Print Layout' and also have a value for 'Change Size in' entered; additional, I suspect that you have for 'ordered Qty' field a tick set for 'Block Overall Font Size'?

What I experienced in the past as well is, that I needed to recreate the field that 'causes issues', and set the 'original field' to invisible (include change the values for height etc).

Kind regards,

Sonja

former_member303406
Participant
0 Kudos

Sonja,

in fact there were two issues. The first one is related to ticking 'Change Size' for Preview. This is solved.

The second one involves printing with the "real" PLD layout, without first previewing. On some printers it is fine, on some others the field grows vertically because the width is too large. The problem is the following: we are asked to create or modify the PLD layouts for the customer. Then we have to check the work: so we print to either to "Microsoft Office Document Image Writer" or to a PDF without previewing. Everything is fine. But when the customer prints on his own printer, then we have the problem. This has nothing to do with the Preview settings.

Gilles Plante

Former Member
0 Kudos

Sometimes this happens as the paper size set in the PLD is different to the papaer size set in the printer?

Not sure of your location, but HP Printers all default as Letter size, in our location we use A4. Sometimes we have to get customers to change the default settings in printers.

The other option is to set the formatting on all cells in PLD to "Adjust to Cell" rather than divide into rows, then they will not resize.

former_member303406
Participant
0 Kudos

Thanks to all of you who came in to help.

Paper is correctly set to Letter. The same document with the same PLD layout, without previewing prints differently depending on the printer picked. For some unknown reason, sometimes the font is bigger and the text does not fit in the space provided. As if for obscure reasons SBO would make the font just a little bit bigger for some printers.

Gilles Plante

Edited by: Rui Pereira on Jan 27, 2009 2:43 PM

former_member187989
Active Contributor
0 Kudos

PLD have lot of limitations.

Hence develop add on for AR invoice using SDK.

Jeyakanthan

former_member187989
Active Contributor
0 Kudos

Read SAP Note 1059781 - Print is different from Print preview

Jeyakanthan

former_member303406
Participant
0 Kudos

Jeyakanthan,

Thanks for the two notes given in reference. I was amazed to learn that that printing through Document printing does not use the default from PLD !

What bugs me is that the result depends on the printer selected.

Gilles Plante

former_member187989
Active Contributor
0 Kudos

Pl refer to SAP Note 1030589 - Printing preference behavior.

It may help you.

Jeyakanthan

former_member303406
Participant
0 Kudos

I have some more details. The name of the document when printed directly is the name defined in the PLD document properties (Display document properties). You can event change the font and its size for the preview. I made some more tests, but that does not explain the differences between previewing or not. The same problem happens with two different printers, one HP PCL6 and one Xerox PostScript.

Gilles Plante

Former Member
0 Kudos

Hi Gilles,

If your going to print your PLD report directly without pressing the print preview button, just uncheck the preview printing layout in the document properties > format tab.

And if your usual practice in printing PLD report is pressing the print preview button before printing,

change the font size in the preview printing layout in the document properties > format tab. Get the same font as the font used in the fields of your report.

To print just like what you see in the print preview, and avoiding changes. Highlight the fields in your PLD report, Go to format tab in Properties window and uncheck the field height adjustment box.

Hope this helps,

Roger