cancel
Showing results for 
Search instead for 
Did you mean: 

VisualStudio debug AnyCpu Project on SAP 9.2 PL03 64bit

Former Member
0 Kudos

Hi People,

i can't debug my project Visual Studio set as AnyCpu   with SAP Bussines Client 64Bit (it works nice with 32Bit) .

This is the error "Connection - Could not find SBO that match the connection string".

I think that i need a new string for Visual Studio Command Line arguments that now is

"0030002C0030002C00530041005000420044005F00440061007400650076002C0050004C006F006D0056004900490056"

Is this the right way?

Thanks for the help.

Alessandro

Accepted Solutions (1)

Accepted Solutions (1)

former_member183373
Active Participant
0 Kudos

Hello Alessandro,

If both 32Bit and 64Bit SAP B1 client is installed in your machine you have to set your debug bit settings accordingly to the client you are working with. 64Bit debug mode for 64Bit client and 32Bit debug mode for 32Bit client.

However if you install both 32Bit and 64Bit version of DI API and if you install only one type of client (32 or 64) on your machine you will be able to work on it with AnyCpu setting is on.

I hope this information helps. Let me know if you have any other questions.

Kind Regards,

Atilla

Former Member
0 Kudos

Hi Attila,

thank you for the reply, it's work now!

Best Regards

Answers (1)

Answers (1)

edy_simon
Active Contributor
0 Kudos

Hi Alessandro,

In windows 10, I found that if you start your sbo as administrator, your VS also need to be as administrator.

Otherwise I will also get the same message.

Regards,

Edy