cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to start idocreceiver

joachimvanpraet
Active Participant
0 Kudos

Hi,

Hi,

We are not able to start the idocreceiver.

This is the output in the command line:

... com.nakisa.renata.commandline.IDocReceiverCmd E:\usr\sap\FP1\J01\j2ee\cluster\apps\Nakisa\OrgModeler\servlet_jsp\OrgModeler\root

Destination connection setting is not set! Please check Image DB connection settings in admin.

IDoc listener failed to start due to issue(s) mentioned above.

The content of the IDocSettings.xml in the .../root/XML folder is:

    <IDocSettings >

        <ImageDBConnection >

            <ConnectionString >[nakenc]PH8bZq7Ycrh/WtuMXo9efIMsi5QHMP959UscP7onAabjrcipeoHEJVdlsN0JuwZ0o//jUJbEq6TneNEIXYY+Zf8rhTGHJHqqw0uKp0OhN6BzKCQOfdjj46xeP1xMwTWgWc/e5UbxvxTaEu877RS+tw==</ConnectionString>

            <ConnectionType >SQLServer</ConnectionType>

        </ImageDBConnection>

    ...

The message is generated by this code in class com.nakisa.renata.commandline.IDocReceiverCmd, but both properties are filled in the XML:

    if ((Strings.isNull(settings.ImageDBConnection.ConnectionString)) || (Strings.isNull(settings.ImageDBConnection.ConnectionType)))

        {

          System.out.println("Destination connection setting is not set! Please check Image DB connection settings in admin.");

          System.out.print("IDoc listener failed to start due to issue(s) mentioned above.");

          return;

        }

What are we missing?

kr,

Joachim

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Joachim,

Have you double checked all of your settings in startidocreceiver.bat?

Also, make sure the following are properly configured in IDocSettings.xml:

<SAPLoginConfiguration> (Should be automatically set through AdminConsole)

<ReceiverConfiguration> (You'll probably have to change this manually in the XML, most likely just <GatewayHost>)

<SenderConfiguration> (The only thing you'll need to change is <RecipientPartnerNumber>)

While those settings won't affect the <ImageDBConnection> (and yours is probably fine), it's good to make sure they're all valid too.

Whenever you do make modifications to any of the XMLs, it's a good idea to upload them into your configuration. Use the "Upload Content" button in AdminConsole to load the changed files, which should be zipped in the following paths:

Root\startidocreceiver.bat

IDocSettings.xml (no folder, just straight in the zip file)

If possible, I also like to include the various connectors, jar files, rfc libraries, etc. in the configuration under some appropriate path. For example:

Root\WEB-INF\lib\sapidocjco.jar

Root\WEB-INF\lib\sapjco.jar

etc.

Uploading all of these into your config gives you the confidence that the appropriate settings are not overwritten when you publish your configuration (and to ensure you retain the original copies in the source application folders).

Best of luck, and let me know how it turns out.

Matthew

joachimvanpraet
Active Participant
0 Kudos

Hi Matthew,

All these settings are correctly published by the AdminConsole.

I changed the location of the sapjco libraries. All libs are in the root/web-inf/lib folder now.

Still the same issue ... Premature end of file ...

Other suggestions?

kr,

Joachim

Former Member
0 Kudos

Hi Joachim,

There are some things in the XML and the BAT files which cannot be changed through AdminConsole. Can you confirm all of the settings you have changed manually in those files?

"Premature end of file" sounds like an XML structure issue. Have you validated that your XML is structured properly in an XML editor?

Note: it could be a different file which is not valid. The application concatenates many XML files together in memory and operates based on that joined configuration. The result is that if one file is invalid, it can cause the configuration in another file not to load properly, and vice versa.

Kind regards

Matthew

joachimvanpraet
Active Participant
0 Kudos

Hi MAtthew,

I've validated all files in the XML folder and all XML-files are valid. (I've tried to format them all with the notepad++ XML plugin and no error returned).

The bat file is pointing to the correct folders:

E:\usr\sap\FP1\J01\j2ee\cluster\apps\Nakisa\OrgModeler\servlet_jsp\OrgModeler\root\.system\application\idocreceivercmd.bat "C:\Program Files (x86)\Java\jre6\bin" E:\usr\sap\FP1\J01\j2ee\cluster\apps\Nakisa\OrgModeler\servlet_jsp\OrgModeler\root E:\usr\sap\FP1\SUM\java\lib E:\usr\sap\FP1\J01\j2ee\cluster\apps\Nakisa\OrgModeler\servlet_jsp\OrgModeler\root E:\usr\sap\FP1\J01\j2ee\cluster\apps\Nakisa\OrgModeler\servlet_jsp\OrgModeler\root\WEB-INF\lib\ FrameworkBin

The only thing we've changed in the xml-files is the

<ReceiverConfiguration >

                    <GatewayHost >

in the idocsettings.xml.

The connectionString in the idocsettings.xml is using an encrypted string ... maybe there is something missing?

kr,

Joachim

Former Member
0 Kudos

Hi Joachim,

The connectionString is populated by AdminConsole based on the SAPImageConnection settings. If you tested the connection through AdminConsole and it succeeded, this should be fine. You can check if the encrypted string matches the one in AppResources\dataconnectionconfiguration\SAPImageConnection.xml, but I think you'll find them to be the same.

For the other settings, I can't vouch for all of the file and folder paths, but your last parameter is probably incorrect. "FrameworkBin" should most likely be "NakisaFrameworkBin". At least that is the name of the file in every OrgModeler build I have worked with. Don't know if it is what's causing your issue, but it should be changed if it does not match the file name in WEB-INF\lib folder.

Also, make sure <SenderConfiguration><RecipientPartnerNumber> matches your recipient settings in your backend system. The default setting is a recipient in Nakisa's development environment. So, this most likely needs to be changed in your customer environment.

Best regards

Matthew

Answers (0)