cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to configure Nakisau2019s SAPExtractor due to connection error

Former Member
0 Kudos

Dear All

We are unable to configure Nakisau2019s SAPExtractor.

In Destination option, when we test for connection the error message appearing is u2013 u201CConnection Failed:[jcc][10165][10051][4.11.69] Invalid database URL syntax: jdbc:db2://localhost:5912/extract:user=OCDADM;password=;. ERRORCODE=-4461, SQLSTATE=42815. Null.u201D

Nakisa version 3.0 has been successfully implemented

Database used: DB2 (16 bit table size) [we are currently not using 32 bit table size]

Source - SAP connection is successful.

Destination Database details:-

Server Type: DB2

Server Name: localhost

Initial Catalog: extract

Kindly guide.

Regards

Ravindra

Accepted Solutions (1)

Accepted Solutions (1)

lukemarson
Active Contributor
0 Kudos

Hi Ravindra,

What version of DB2 are you using? Did you remove the password from the string or do you not actually have one for the database? This would certainly cause a problem.

Can you connect to the DB2 database using the JDBC driver seperately?

Best regards,

Luke

Answers (2)

Answers (2)

lukemarson
Active Contributor
0 Kudos

Hi Ravindra,

Can you confirm if your question was answered? If your query has been answered, please close the thread and mark it as answered. If the post remains open with activity for a month it will be closed automatically.

Best regards,

Luke Marson

Former Member
0 Kudos

Hi Ravindra,

The correct URL has the syntax

jdbc:db2://[host]:[port]/[database]

e.g. jdbc:db2://191.169.11.5:5000/SAMPLE

Please check SAP Note 784264 and test the JDBC database connection with the used URL.

Hope this helps,

Matthew

Former Member
0 Kudos

We are having a similar problem. We are using a stacked DB2 Database that is not using the standard port number of 446. Does anyone know of a way to change the port number that Nakisa tries to use for connection?

I have done the items in the sapnote 784264 and tested the connection using the port number that we gave it and the connection works fine, tested using the default port of 446 it fails as expected. I cannot find any place to change the port number in the Nakisa app to make it look at the correct port number.

Former Member
0 Kudos

Hi Bill,

The port number should be set up in the connection string.

To define custom port, it is a generic way of specifying with server

name separated by colon like myServerName:6922 or myServerName.

mydomain.com:6922

Server Name: myServer.domain:portNumber

Note: Please include both server name and domain if only specifying

server name does not work.

Also please note that there should be no space between serverName:port.

Hope this helps,

Kind Regards,

Matthew

Former Member
0 Kudos

The connection string in the settings of Nakisa.