cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to create Vendor but giving error

former_member191939
Active Contributor
0 Kudos

Hi Gurus,

When i am trying to create vendor in FK01 i am getting an error,the error is "ACCT GROUP USES EXT.NOASSIGNMENT.SPECIFY AN ACCOUNT NUMBER".

Please help to solve the error.

Thanks In Advance

Regards

Vincent

Moderator: Please, avoid asking basic questions

Accepted Solutions (0)

Answers (4)

Answers (4)

msshihab1987
Active Contributor
0 Kudos

HI Friend

Please input A Number in the Vendor Field , so the system will accept the number if the same number come under the Number range , because here in the Account Group the number range assigned as External Number range that means the system will not automatically assign the Number range. This External number range are used to create Employee vendor, so that we can create the employee number as Employee Vendor in the SAP System to identify the employee vendor easily.

You can also try to create vendor by chaning the account group , most probably most of the standard account groups are assigned with Internal number range, in that case the system will assign number from the available number range

You can check this Number range status by using T cod XKN1

You can see a Check box in the last Column that specify whether the number range is internal or external

you can assign this number range into Account Group in the Following IMG Path

Financial Accounting (New)>Accounts Receivable and Accounts Payable>Vendor Accounts>Master Data>>Preparations for Creating Vendor Master Data>Assign Number Ranges to Vendor Account Groups

former_member191939
Active Contributor
0 Kudos

Dear Shihab,

How to input a number in the vendor field.

msshihab1987
Active Contributor
0 Kudos

HI Friend

Please check the number range and enter like this in the image

former_member191939
Active Contributor
0 Kudos

Thanks Done

former_member193513
Contributor
0 Kudos

HI Vincent

When your number range is external it means that you have to manually give the numbering.

If it internal number range, it will be picked up by the system automatically

In your case as the number range is external, while creating vendor in FK01

Give your company code , account group and manually give the number

To check the available no, go to KNA1 and KNB1 table and check what is the last vendor created in the system and give the subsequent number for the new vendor

Hope it will help you

Regards

Prasad

Former Member
0 Kudos

Hi

Go to Transaction code XKN1 and deactivate the External Number Check box

and try to create the Vendor.

Or

If you want to use the External number ranges for creating the vendor give the number while creating the vendor in XK01

Regards,

Kiran

Former Member
0 Kudos

when in the first screen you input company code and account group, fill in the field "Vendor".

former_member188063
Active Contributor
0 Kudos

Hi Vincent, that's because External No. Range option has been selected in the Vendor No. Range. Go to XKN1 > Change Interval and uncheck Ext. No. Range option and try creating a vendor.

Regards,

SM*