cancel
Showing results for 
Search instead for 
Did you mean: 

sudden DI error: Connection to SBO-Common has failed

Former Member
0 Kudos

Hi guys,

I really need your help!

I was connecting to B1 database via DataInterface

using the parameter UseTrusted = FALSE.

All of the sudden the connection works only with

UseTrusted = TRUE otherwise I get this error:

-111 Connection to SBO-Common has failed.

What could have happened?

The only thing I did in the meanwhile is to add

a new company database to my B1 system.

Does anybody know what I need (users, logins etc.)

to connect as previously?!?

thanks a lot,

hope to hear from you soon.

francesca

Accepted Solutions (0)

Answers (2)

Answers (2)

rasmuswulff_jensen
Active Contributor
0 Kudos

The problem is that a database must have lost the OBSCommon user (Used in 2004 when usetrusted = false and no dbusername and dbpassword is provided). Go to Enterprise manager userlist and verify that OBSCommon user is dbowner.

NB.

From 2005A the Obscommon user will be gone due to sequrity reasons so you might reconsider setting usetrusted to false and not providing the dbusername and password, if you want you addon to work in future versions

barend_morkel2
Active Contributor
0 Kudos

Ensure you can see (ping) the SQL server on the network you are using...

Former Member
0 Kudos

My PC is the server!!!

Former Member
0 Kudos

Hi Franscesca,

I always do the following when I have login problems. I attempt logging in with the data transfer workbench. Install it on your machine and try and connect with it. Once you can connect you know which setting is giving you a problem. I know this seems very tedious, but has done wonders for me.

Hope it helps,

Adele

Former Member
0 Kudos

Adele and Rasmus,

thanks for your reply.

Rasmus: I checked all my db and the user OBSCommon

is defined as dbowner in each company db and also

in SBO_Common! It also has a login name!

I still can connect only if UseTrusted = True

or if I add dbuser (sa) and password in DI Company Object.

Any other idea about what I need to do to restore previuos state in my system and connect with False and without dbuser info?

Adele: I installed DTW and tried to connect.

If I connect without Windows authentication I have the same error as with DI: Connection to SBO_Common has failed.

With Windows authentication I can see my company dbs and connect. Now, what can I do connect also without windows authentication?

Thanks a lot for your help!!!!

francesca