cancel
Showing results for 
Search instead for 
Did you mean: 

Step create SPFILE ....*ORA-12560: TNS: protocol adapter error.*

hanse_atik2
Participant
0 Kudos

Hi All,

by the installation of R/3 4.6C for a pilot system for the upgtrade from 4.6C to ECC 6.0 the installation hangs at step:

-


Create SPFILE: (this step creates the oracle server profile (SPFILE) from the up to now used PFILE (ini<SID>.ora). -


when I try to connect to DB via: connect /as sysdba I get the error message:

ORA-12560: TNS: protocol adapter error.

I know this oracle file can means many things and the R/3 is running fine. I copied the brtool from source system but it does not help. Until now there is no data from source. Its a new installation and we want to fix this error before we began to copy the data to the pilot system.

Anyone from you has a good feedback for me?

Thanks in advance

Atik

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Hanse,

Just check whether all your Oracle services are running.

Also go to <ORACLE_HOME>/network/admin/tnsnames.ora,

Check whether the following entry is there in the tnsnames.ora

<your databse sid> =

(DESCRIPTION =

(ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

(CONNECT_DATA = (SID = <your databse sid>))

)

2) Check whether the listener is running.

3) Do a R3trans -d as <sid>adm. check the trans.log file for further details.

Regards

Thilip kumar

hanse_atik2
Participant
0 Kudos

Hi Thilip,

thank you for your reply.

1) Oracle Service are running fine:

- OracleJobschedulerSID ... disabled

- oracleSID102iSQL*plus .......manual

- oracleSID102TNSListener.... started

- OraclServiceSID ..................started

2) TNSnames.ora is ok:

###############

  1. Filename......: tnsnames.ora

  2. Created.......: created by SAP AG, R/3 Rel. >= 4.0A

  3. Name..........:

  4. Date..........:

################

PLT.WORLD=

(DESCRIPTION =

(SDU = 32768)

(ADDRESS_LIST =

(ADDRESS =

(COMMUNITY = SAP.WORLD)

(PROTOCOL = TCP)

(HOST = bysapp1)

(PORT = 1527)

)

)

(CONNECT_DATA =

(SID = PLT)

(GLOBAL_NAME = PLT.WORLD)

)

)

3)The Listner is running:

see the services.

4) R3trans does not work: Error message is:

..:\usr\sap\PLT\sys\exe\run>r3trans -d

This is r3trans version 6.05 (release 46D - 30.09.03 - 16:30:42).

2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

r3trans finished (0012).

I can see nothing wrong in this issue.

Thanks in advance.

Best regards

Atik

hanse_atik2
Participant
0 Kudos

sorry, the r3trans does not work that where I am working of course to find why its does not work. maybe this is the problem? Thanks

Former Member
0 Kudos

Hello Hanse,

Also check alert<SID>.log for some morte clues regarding the error.. Did you apply any patch recently or did anyone messed up with Oracle libraries?

Regards

Thilip Kumar

hanse_atik2
Participant
0 Kudos

Hi,

the system is new. We installed oracle 10.2.0.1.0 and patched to 10.2.0.2.0.

You mean the alert file: alert_SID.log?

Which one?

1) \oracle\SID\saptrace\background\alert_SID.log

2) \oracle\SID\102\RDBMS\trace\alert_SID.log

Thanks

Best regards

Hanseatik

Former Member
0 Kudos

Hi,

i had the same problem........., installed Oracle client and the problem was solved

extract the oracle client file and put it in your kernel

Thanks and Regards

Abdul

hanse_atik2
Participant
0 Kudos

Hi Muhammad,

the oracle client was installed. I just extracted the file from Directory:OCL_Windows_I386 again and copied them including the directories. \full and \lite to ..\exe\run\.

But it does not help.

My 4.6C installation still hangs at 98% and no connection to DB via connect /as sysdba. R/3 is running fine.

My platform is windows server 2003 x64. Should be this a problem?

Thanks

HanseAtik

hanse_atik2
Participant
0 Kudos

Hi all,

I would like to share teh solution with you.

The solutions are:

1) the problem of: no connection to DB was that the enviroment variabel LOCAL=SID should be addedd.

2) the problem with Spfile: I have to stop R/3, create the parameter PERLIB=..\u00F2racle ..lib and start the installation.

Thanks to those who tried to help.