cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Business One 10.0 FP2208 - Failed to get access token, contact your administrator

Hi experts,

I am trying to get SAP Business One 10.0 FP2208 up. After server & client installation and when I try to login to SAP Business One (via both ip address & server name), I failed to login as I get the system message "Failed to get access token, contact your administrator". Kindly assist. It's urgent.

0 Kudos

Kindly refer to the attached screenshot for your reference.

kenneth_g
Explorer
0 Kudos

Did anyone ever find a solution to this?

It has started happening on my developer machine too, where both the client and server is installed locally. IP addresses are never used, only the machine name. If I try to access the SLD through https://machinename:40000, it will redirect me to port 40020 where I can log in just fine, so auth and SLD is working as expected.

It used to work just fine, but after I returned after a small hiatus it has spontaneously stopped working.

Accepted Solutions (0)

Answers (9)

Answers (9)

wenli_chen
Employee
Employee

Dear Yan Yan

It seems to be issue in SAP Note 3251679

that happens with only FP 2208, with error message

- Invalid username or password

- Failed to get access token, contact your administrator

workaround:

  1. Check and follow the steps in the chapter Adding a User for Logging into the Authentication Service in the guide Identity and Authentication Management in SAP Business One.

https://help.sap.com/docs/SAP_BUSINESS_ONE_IAM/548d6202b2b6491b824a488cfc447343/d09ae6c2a0f04074907d...

  1. In a Web browser, access the SAP Business One authentication service by navigating to the following URL:
    https://<Server Address>:40020/auth/admin/master/console/#/realms/sapb1/users
  2. Log into the SAP Business One authentication service with the user account created in step 1.
  3. In the left menu, choose Users.
  4. In the right panel, choose Lookup tab.
  5. Choose View all users.
  6. In the user list, delete all users except B1SiteUser.

thanks & regards,

Relle

kenneth_g
Explorer
0 Kudos

Relle you legend, that worked! Thanks so much!

(I had to remove '?state=DRAFT' from the link, or it wouldn't open)

wenli_chen
Employee
Employee

Dear, its glad to know that helps, and accepted.

thanks & regards,

Relle

PiotrM
Discoverer

Hi,

I had to open port 40021. Not only 40020

I found which port to open, when I had tried to open SLD ControlCenter outside of server.

Regards

Piotr Maj

kentishbh251
Member
0 Kudos

In the client machine, the host file found under Windows>system32>Drivers>etc . Add your server IP and the full server name (see system under control panel of your server for full name)

Example

your server IP, space, full server name

192.168.32.21 full server name

Hope that helps

0 Kudos

Hi


The note https://launchpad.support.sap.com/#/notes/3251679 work perfect when replace SSL.

🙂

SAdmin
Explorer
0 Kudos

We have met same problem ,because we are in Testing envionment,

so the DNS cannot reach the servername.domian-name.local

then I plus one static route point into SLD server address in Hosts file, it works.

I think in our Productive environment without this problem cause we have DNS Server in Domain .

Hope this can give you some ideas.

martin_fodor
Explorer
0 Kudos

We are also facing the same problem with the server name based configuration, reconfiguration with replacing the server name by IP address does not resolved our problem.

0 Kudos

Hi Martin,

There are new users being automatically created by SAP in MS SQL Server Logins. Kindly also make sure they are not locked. For my case, it is locked and I have to manually unlock it. sql-server-users.png

martin_fodor
Explorer
0 Kudos

Hallo chongyanyan,
thank you for reply, but this is not our issue.

Login to DB by client installed on server is successfull under the same account, that tries to login from client on customer workstation. The new SQL accounts based on the DB registration in SLD are not locked.

Also tried login with several SAP accounts in multiple DB's. IMHO there is infrastructure problem. Also verified port exposing, and over all a new firewal rules has been created to open all necessary ports for SBO.

nizam_babayev
Participant
0 Kudos

Does anyone know how to fix this problem?

Hi Nizam,

I managed to resolve this issue myself. What I did was, I uninstall all SAP Business One related components (servers, clients) completely, then I reinstalled the server components, using server name, and follow with the installation for the client. Remember not to add the server's ip address into the SLD (DB Instances and Components tab), else it will result into the error I faced earlier. Just proceed to login with server's name.

jayesh_agrawal
Explorer
0 Kudos

Hi,

We are also facing the same problem and resolved by replacing the server IP address with the server name resolved our problem

regards,

Jayesh

nizam_babayev
Participant
0 Kudos

Please can you explain how to do it ?

Thanks in advance

ANKIT_CHAUHAN
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi chongyanyan,

This issue can be related to the fact that the Port 40020 should be exposed to the internet, for the Authentication Service in the System Landscape Directory.The service is one part of the SLD.

The admin guide has the full list of ports that need to be exposed.

Kind regards,

ANKIT CHAUHAN

SAP Business One Support

0 Kudos

Hi Ankit,

I did come across this when I check the Administrator's Guideline, but not too sure what this means and how to configure it. Does it means, I configures the list of ports to be made available in the Windows Defender Firewall? But based on note 3297866, it needs to be configured in SLD and I am not too sure what I should do. Appreciate if you could enlighten me. Thank you.

ANKIT_CHAUHAN
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi chongyanyan,

Your IT Admin or Network Admin should be able to help you.

Check this link if it helps: HOW TO OPEN PORTS IN WINDOWS?

Kind regards,

ANKIT CHAUHAN

SAP Business One Support

0 Kudos

Hi Ankit,

The port 40020 has been defined earlier on but I still encounter this issue.

ANKIT_CHAUHAN
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi chongyanyan,

In that case, kindly create an incident for SAP Business One Support Team under the component SBO-BC to get it investigated.

Kind regards,

ANKIT CHAUHAN

SAP Business One Support