cancel
Showing results for 
Search instead for 
Did you mean: 

RPTIME00 - "Error entry no. 01 Employee not at work"

Former Member
0 Kudos

Hello expertise geeks @ SCN,

Have been workin on TM and trying to do Time Eval. I have uploaded the clock-ins n clock-outs for a employee for 1 year (starting from the date he joined the organisation) in IT2011. But when I proceeded to run time eval thru RPTIME00 (since mine is positive time management) for 1 year (mentioning the last clock-out date of the employee in Eval upto field), the "Error entry no. 01 Employee not at work    09.02.2011 Incorrect processing for EE000000XX EEName" error message is pummelling on my screen for every date he clocked in and out.

requesting all to provide me the solution on this and help me out in getting this fixed.

Thanks in advance.

TahirMuzza

Accepted Solutions (1)

Accepted Solutions (1)

rajasekhar_reddy3
Active Contributor

Hi,

The below error comes from the following rules TE20 from line  000060 N N N 0      COLER01E.

First copy the rule into ZE20 and change COLER01E as COLER01I (Here I standard for time evaluation will process but error message will be raised. But if it is 'E' it will stop the processing of the rule and schema.

You have copied the standard schema right ?

"Error entry no. 01 Employee not at work    09.02.2011 Incorrect processing for EE000000XX EEName".

Check the day you are running time evaluation whether entries are there in IT2011 or IT2002 . if entries doesnt exits it will just give a message but time evaluation will continue .

You can check the error messages in PT_ERL00 T-code.

Regards,

Raja Sekhar

Former Member
0 Kudos

Hi Raja Sekhar,

Appreciate on ua in-put. I exercised the way u suggested, displayed TE20 to check for COLER01E ..

But there is nothing as such reflecting in TE20 screen.. Plz check the screen-shot below and guide me till the end..

I wud also like to know if this error is due to PDC recalculation field in IT0003??

rajasekhar_reddy3
Active Contributor
0 Kudos

Hi,

I am telling plz dont change the TE20 Standard rule ur still checking the standard rule.

Please copy the TE20 rules and ZE20 and replace in the schema.

Please copy the standard schema into Z

Here you can see COLER01F right change it to COLER01I

Regards,

Raja Sekhar

Former Member
0 Kudos

Thanks Rajesh for suggestion,

Copied TE20 to ZE20 and changed COLER01F  to COLER01I (hope the last letter is "i" which is for information).. Plz let me know wht next is tobe done..

Regards

TahirMuzza

rajasekhar_reddy3
Active Contributor
0 Kudos

Hi,

Can you plz go to PT60 and execute with schema . check still any error is coming for the same employee.

Check all the error messages in PT_ERL00 which are formed in Time evaluation.

Regards,

Raja sekhar

Former Member
0 Kudos

Well Rajesh, the error message still persists.. Plz check the screen shot below..

I did change TE20 to ZE20 but dint enter / maintained the changed rule any-where.. Do we need to maintain it anywhere??

regards

TahirMuzza

Former Member
0 Kudos

What is the time evaluation status you have maintained?

Former Member
0 Kudos

Time Eval Status = 01

Former Member
0 Kudos

Hi Tahir,

Is your problem solved? .If not Deactivate the TE20 rule in your schema and insert the ZE20 rule which you have been changed or copy the TE20 rule ZE20 rule and change the wherever is COLER01F and COLER02F to COLER01I and COLER02I.

before executing time evaluation keep time evaluation fields blank in 0003IT and run the time evaluation for the month of  02, 2011.

If you are getting same problem yet, then check the daily workschedule hours and ur time events hours.

Delete the time events from 2011 and re-create the time events

Regards,

Devi

Former Member
0 Kudos

Hi Dev N,

A valuable reply.. was quite helpful..

I exercised the way u suggested, Yes my  daily workschedule hours and time events hours were mismatching. I deleted everything from IT2011 n re-entered according to workschedule..

than I copied TE20 to ZE20 n changed COLER01F and COLER02F to COLER01I and COLER02I in ZE20.

Back in ZM00 (which was copied ffrom TM00) I entered ZE20..

Emptied Time Eval Field in IT0003...


Finally I ran PT60... FOUND A NEW ERROR -->  "Error entry no. 03 Clock-in cannot be delimited"

as u said, I worked on TE20.. But I believe this error is in TE30, as the error message says ::: Call Rule TE30  "Error entry no. 03 Clock-in cannot be delimited"

Requesting a help from u on this issue..

Ua replies wud be highly appreciable ..

Cheers

TahirMuzza


Former Member
0 Kudos

Hi Tahir,

That would be the standard behaviour. To stop processing in that case. If you just the message to show up but not to stop the time processing you will have to make a change in rule TE30. If you see rule TE30 you will see that you have an operation like this one:

COLER03E--> COLER is the operation to get the message from table T5554. 03 is the number of the message. And the key here is the "E" after 03. This E is the one that is use to terminate the time processing. You can take out that E and the time will continue just showing the message. You also have the option to put and F or an I.  Change the E to I where an COLER03, COLER04, COLER05 , COLER06 etc.). This will allow the process to continue after this point, but you have to check the further behavior.

Do the copy TE30 to ZE30 and insert the copy rule into your custom schema and deactivate the TE30 Rule in the copied schema. By this way you can resolve your issue.

Regards,

Devi

Former Member
0 Kudos

Cheers DeviN,

I got the solution, Thanks a bunch..

Regards

TahirMuzza

Answers (2)

Answers (2)

Former Member
0 Kudos

Hello Readers,

was not expected this to happen again... but my one more thread in SCN went in vain...

Issues on Attendance are glued to me... but no support / help frm SCN on every thread I communicate here on attendance.. Posted many threads (on different issues but all related to attendance) here.. but none provided any solution or atleast a near to solution..

this makes me think "shud I be postin any thread in future to get my queries solved here?? " ahhh.. gotta think..

with bad experience @ SCN

TahirMuzza

Former Member
0 Kudos

Expecting more in-puts on this... Plz help me sorting out this..

Regards

TahirMuzza