cancel
Showing results for 
Search instead for 
Did you mean: 

Red Arrows not showing in debug mode

Former Member
0 Kudos

Hi Experts,

I have a few processes running in my scenario dropping messages on a queue.

For some reason only the main trigger shows red arrows and the rest does not ?

Does someone have an idea how I can solve this because I need to debug those parts but I can't see that red arrows.

Kind Regards,

Brenden Draper

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi All,

Please note that the ASN is the first trigger then putting messages to 2 queues ProcessASNMod 1.1 and ProcessASNMod 1.2.

Please see the Start and End Time the Sub Process finishes before the Main trigger, don't know if this can be the origin of this issue.

Please assist ...

Kind Regards,

Brenden Draper

Former Member
0 Kudos

Hi All,

To explain the complete process...

The file comes in and is put to the ASN queue.

1. The ASN scenario is fired putting the same result to a ProcessASNMod1.1 and ProcessASNMod1.2 queue.

2. ProcessASNMod1.1 scenario is fired putting a result message to a ProcessASNMod2 queue.

3. ProcessASNMod2 scenario is fired.

4. ProcessASNMod1.2 is fired.

And I am only able to see the debug arrows in the ASN and the ProcessASNMod2 scenarios.

ProcessASNMod1.1 and ProcessASNMod1.2 arrows does not show.

Can any one tell me why this would happen ?

Kind Regards,

Brenden Draper

Former Member
0 Kudos

Hi Brenden, are the scenarios that read from the queue getting the inbound message (payload S) ?

Former Member
0 Kudos

Hi Silvio,

Well the process works but I can't debug so I cannot see what is received but I have tested the phases separately and it works.

So it seems that even the transactions are created but the debug arrows does not show.

So if it fails I cannot get to the reason.

Kind Regards,

Brenden Draper

Former Member
0 Kudos

Hi All,

There is a workaround when getting this issue, but the origin of the issue are still being determined by the B1IF developers.

Go to the specific transaction type Debug in the message log.

Kind Regards,

Brenden Draper

Former Member
0 Kudos

Hi All,

This bug in B1IF will be fixed in SAP9 PL11 with confirmation by SAP.

Kind Regards,

Brenden Draper

Answers (0)