cancel
Showing results for 
Search instead for 
Did you mean: 

Print Preview For Sales Document not getting generated

chandansb
Active Contributor
0 Kudos
1,177

Hello Experts,

We have integrated C4C with ECC using HCI. All our transaction data scenarios are working fine except for PDF preview of Quote and Order.

For Request for Sales Quote and Request for Sales Order when we click on document number, the pdf does not generate and gives the error:: "PDF Document could not be retrieved".

For Customer Quote and Sales Order when we click on document number, the pdf does not generate and gives the error:: "No Communication Arrangement found".

We have configured the communication arrangements correctly and have configured the required artifacts on HCI as well. We are getting COMPLETED status on HCI for Print Preview Artifact.

Also want to mention that we are unable to create the below mentioned Service.

We are not able to find the External Service name mentioned for this. Kindly help me understand why I am not able to get the PDF document for this created despite that I am getting success in HCI.

Thanks and Regards,

Chandan Bankar

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Sorry for replying late but I am working on lot of things at the moment and so, didn't get time.

Firstly, for this remote Query service, I had to modify standard approach as SAP's version didn't work for me but now I see that it actually didn't work for anyone. So, I will say the approach I followed.

Here are the changes I did to the std. approach:

ECC: Nothing. Just followed the std. configurations. Created a service in SOAMANGER and assigned all authorizations to the role. I too didn't find the query service at the start. I just deleted and re-created the service again in SOAMANAGER and it came up in the authorization assignment list then after.

C4C: There were two Outbound services in the outbound scenario but I didn't use both. I unchecked one. There was no deprecation message as shown in the below screenshot when I worked but I see this now in a weird way.

     So, the million dollar question would be why did I uncheck one service and how to know which is the right service to check? Well, I cross checked with the Sender side wsdl within the PrintPreview iflow of HCI and it matched with what I checked in C4C perfectly. Other one also has the fields as in HCI service but it also has additional fields with a structure mismatch I guess. So, the message was not going out properly for each sales document type when clicked in Opportunity instance.

If it is the case that what I've used is going to be deprecated, then I am not sure how SAP's gonna handle this as checking the other service would not make the scenario work as the structures are different. May be, SAP will come up with different sender side wsdl in HCI's iflow as well. Let's see.

HCI: Now, that both Sender and Receiver configurations are done, it's time to check for any modifications in HCI. The actual point was despite these configurations, I still got errors in C4C. When checked in depth, I found that Output Types are not being sent at all in the payload received by ECC. I mean, let's think logically here for a sec. See the Request that ECC is receiving in the below screenshot.

Without two important attributes, we can never get the right PDF. They are SalesDocument Type (if it is an Inquiry or Quotation or Order) and Output Type. So, I thought of workaround that would really work in my case and changed HCI config. Finally, I got the below Request in ECC and pdf in C4C started working.

So, what did I exactly change in HCI ?

     I had to figure out some way to differentiate three sales documents to let know ECC to pickup document from the right output type. You have to know the output types first from V/30.

So, in my case, I took the advantage of different Sales Documents having different Number ranges. Then comes the question how do you pass these Output Types based on Number Range? Here's where HCI part comes into picture. If you see the std. iflow, there is no mapping at all. So, I created a new mapping and assigned it to iflow. Below screenshot was taken from my mapping...

Lemme know if you need any further clarification on this.

chandansb
Active Contributor
0 Kudos

Thanks Srivatsava for the reply.

I have unchecked the check box on C4C as you have done and now I can see a pop up coming up but without any PDF content.

But for the changes that you did for mapping, I couldn't see the message mapping as you have shown in the screen shot. It looks as shown in screen shot below. Could you please elaborate more on the custom mapping as we have never worked on any custom mapping scenario.

Regards,

Chandan

Former Member
0 Kudos

There is no Mapping in the standard iflow. What I've posted is the thing I created. It's basically a new mapping. May be if you have any developers on your side, they will understand. It's easy

This mapping just tells the iflow which OutputType to pass based on the Number Range.

chandansb
Active Contributor
0 Kudos

Hello Srivatsava,

I have made the mentioned changes in mapping file which we have downloaded from Standard scenario on HCI catalog. (I am clueless why you didn't get the mapping file for Preview scenario) But yet I am still getting the No PDF found error in the blank pop up.

So according to my understanding now my XML should have default Y for IV_PRINT_ALWAYS and respective Document Type in IV_KSCHL.

Also the direct mapping exists for IV_VBELN.

Please note that I am using SalesDocumentPrintPreviewQuery instead of ns2:ERP_LORD_GET_PRINT_PREVIEW that you used on both side. Since for us C4C message would be mapped to ECC IDOC.

Hope my understanding is right. Kindly suggest.

Regards,

Chandan

Former Member
0 Kudos

I want you to understand how this std. iflow works.

ECC webservice is used as Outbound webservice in C4C. So, by the time the call goes out of C4C, structure of the call will be of ECC's but not C4C's. Got it? So, both sender and receiver of this iflow are actually ECC's.

So, you have to use the same schema in both Source and Target of mapping. Mappings in iflow are not a scenario specific development. They are supposed to be done that way.

Next thing, tracing your calls in ECC. Go to srt_util and add your service user over there and trace the payload. This transaction is to be used only for webservice calls. Good luck.

Former Member
0 Kudos

Hi Srivatsava,

Thanks for the detail understanding.

As you suggested, we have tried but still we are getting same message "No PDF found".

Also SRT_UTIL is not giving us any logs in the ERP system.

Please find below screenshot for the same & advice path forward..

Thanks in Advanace...

Anand,

Former Member
0 Kudos

Ok. If you don't see any logs in srt_util with the service user added, then you should probably check the status of message communication in HCI. How abt that?

Former Member
0 Kudos

Once we have done these changes, we are not getting any status or logs of this particular iflow, which we have prepared.

So i doubt it's reaching still HCI, with these customized mapping which we have done.

May be we can have quick call to discuss and solve this out, it will be highly appreciated...

--Anand & Chandan...

Former Member
0 Kudos

Pls add me as a skype contact. ID on my profile. I will be online mostly at nights.

I will be invisible. Just add me. If I am there, I will respond. We can talk then.

Answers (1)

Answers (1)

A-J-S
Active Participant
0 Kudos

HI Chandan,

I am facing the same issue, No PDF found.

Were you able to resolve this ?

I have smartforms for the output type.

Thanks and Regards,

Ajith J