cancel
Showing results for 
Search instead for 
Did you mean: 

Payment advice email to user/sender

Former Member
0 Kudos

Hi Gurus,

Payment advice emails are generating & sending to vendors without any issue after F110 execution by all users but some of the users are able to get the same into their mail box & some are not.  Where I need to check in order to get the notification email to users.

Thanks in advance.

Accepted Solutions (0)

Answers (3)

Answers (3)

former_member182098
Active Contributor

It would not act differently for different vendors.

Please check your Function Module used in FIBF.

You can still see the failed one in SOST, as F0570 message relates to SOST

Give the relevant date in SOST, remove 500 threshold limit, on the send status check tab, select all check boxes.

Please note in test systems normally the outgoing mails are restricted, if you want to test, then you need add that email address manually in SCOT. Please also check you have correct email address.

Kind Regards,

Ravi

0 Kudos

Hi

Same scenario. How does one get email text ? Tried creating text object in SO10 and altering ZSAMPLE_PROCESS_00002040 with   "c_finaa-namep = 'F110_EMAIL_TXT' where  'F110_EMAIL_TXT'." is text ID.

regards,

Darryl


former_member182098
Active Contributor
0 Kudos
0 Kudos

Hi Ravi

Thank you very much for your swift response. I have read the notes and noticed that my Zed copy of RFFORI06 did not include some logic [ eg. check_mail_text ]. The copy from SE38 did not include SAP enhancements. I have now created a new include and copied using ctrl^A and ctrl^C to copy all logic. Saved and activated and voila, it works.

Thanks again.

regards,

Darryl

former_member183378
Active Contributor
0 Kudos

HI Jyothi,

Please check the payment advice notification mail in SOST t code. Please give the date and timings in SOST code and click display option then you can able to view the pyt advice details.

Please get the date and time details in F110 print job Payment Advice Notes Sent by Mail in F110.

I hope it helps else revert us with your query.

Thanks & Regards,

Lakshmi S

Former Member
0 Kudos

Hi Lakshmi,

Thanks for your prompt reply.

I have checked in SOST and no mail information generated for that particular date(F110 executed date) & on this particular user id.  It was successful in my testing.  Please let me know where could be the problem?

More interstingly, in F110 payment job log, the below error triggered:

Error during sending of mail: Return code0, LIFNR/KUNNR 0001001296 co. code XXXX

Message no. F0750

Thanks.

vinod_vemuru2
Active Contributor
0 Kudos

Hello,

Check below points and let us know.

1. Compare vendor master data b/w production and test. Is there any difference.

2. Is valid e-mail ID maintained in vendor master and is that domain allowed in SCOT?

3. Is same user who runs F110 is able to send mails to other vendors? If no, it could be authorization issue.

4. You may have selected to send fax instead of e-mail

If all are fine, create new vendor with exactly same details in test system, post a document and try F110 with same variant as of production.

Thanks,

V V

former_member183378
Active Contributor
0 Kudos

Hi Jyothi,

For that particular vendor it is checking to send fax's.Please check did you maintain the fax config in vendor master data once. If you haven't configured to send faxes then pls remove faxes on those vendors. I hope it would resolve your problem

Thanks & Regards,

Lakshmi S

ajaycwa1981
Active Contributor
0 Kudos

Hi Jyothi

seems an issue with your code, possibly due to hard coding

Ask your ABAPer to debug the BTE 2040 in FIBF or debug the program you are using to trigger the payment advices

Br. Ajay M

Former Member
0 Kudos

Hi Ajay,

Thanks for reply.

Now user reported that he is not able to send also.

I have checked BTE 2040 & 2050 and these company codes were maintained with the combination of payment method & also checked it with BASIS Team for email node activation in SCOT.  Seems everything fine. user has maintained correct payment method & variant in F110. I have tested in acceptence system with same parameters and able to see the payment advice in SOST

Not able to find where the problem lies in production.

Thanks in advance

Former Member
0 Kudos

Please share your inputs as this is urgent issue to resolve.

Thanks in advance.

suma_mani
Active Contributor
0 Kudos

Failed tranactions payment method must be differ ,whcih you hardcoded in BTE. Technical consutant can help you. Check authorization objects also for AP user id's.

Regards

Mani Kumar

Former Member
0 Kudos

Hi,

They have used same payment method and not able to send for any of the vendors.

Thanks.

suma_mani
Active Contributor

Hi Jyoti,

Take one vendor number who doesn't receive any emails once done the payment > Go to FK02 > Enter vendor number > Company code > select payment transactions under company code settigns > check whether selected or not payment advice by EDI check box. It should be select

Regards

Mani