cancel
Showing results for 
Search instead for 
Did you mean: 

OrgChart - root of OrgUnit defined by user

Former Member
0 Kudos

Hi all.

I'm configure OrgChart Module. I'm trying to define the OrgChart root depending by the user are logged.

For example:

When i logon with the user:joao1, the root of OrgUnit should be 11100000

When i logon with the user:joao2, the root of OrgUnit should be 00000111

Aditional information:

In SAP the user joao1 belongs to OrgUnit 11100000 and the user joao2 belongs to OrgUnit 00000111

How can i do it?

I have already following steps:

  • configure the Genertal Settings of Organizations Structures with OrgChart root value source = User record

     or

  • configure the Genertal Settings of Organizations Structures with OrgChart root value source = User Id

but i have the error: "Cannot find the root of your OrgChart"

But, when i define the OrgChart Root with the OrgChart root value 11100000, and publish the scenario, the system presents the OrgChart perfectly.

Can you please tell me what am i doing wrong?

Many thanks,

Best Regards,

João Regalado

Message was edited by: Luke Marson - removed request for personal contact details

Accepted Solutions (1)

Accepted Solutions (1)

StephenBurr
Active Contributor
0 Kudos

Set the general settings like this:

Regards,

Stephen

Former Member
0 Kudos

Hi Stephen,

I had already tried, but tried again and gives the following error.

Is attached the error log.

Thanks in advance,

João Regalado

StephenBurr
Active Contributor
0 Kudos

In your first post you listed a different field that you'd put in the "user record field" box.

Can you screenshot your setting in General Settings?

The log implies that it can't find the OU that this user sits in.

Which authentication method are you using? (i.e. how are you logging in?)

Stephen

Former Member
0 Kudos

Yes sorry,

I'm using the logon screen.

In attach goes the screenshot.

thanks in advance,

joao regalado

StephenBurr
Active Contributor
0 Kudos

There should not be any more to this that what you have already done.

Can you check ECC to ensure the user id you are testing with is in PA0105 against an employee.  That this ee is in a position in the Org Unit you are expecting.

I wonder whether you can test the UserPopulationInfo data element via the Data Centre for your user id ... never tried it for this data element, but if you can it might show if the expected OU id is being returned.

Stephen

Former Member
0 Kudos

Hi,

Yes, the system gets the correct PERNR by checking the table PA0105.

However the system retreaves the following error on log error.

"ExpertSeek_Detail1_DataElement" with the comand get data tables.

Can you help us?

Many thanks,

joao regalado

StephenBurr
Active Contributor
0 Kudos

Did you test the data element?

If so, does it also get the correct Org Unit?

If you take this ID, can you search in OrgChart using the same user id and find it? (and view as a chart)

The error "ExpertSeek_Detail1_DataElement" is un-related to your issue ... this is related to SocialLink which I presume you have left disabled. 

Stephen

Former Member
0 Kudos

Hi stephen,

I don't know how can i test the data element.

How can i test?

Thanks in advance,

Best Regards,

Joao Regalado

StephenBurr
Active Contributor
0 Kudos

I wonder whether you can test (preview) the "UserPopulationInfo" data element via the AdminConsole (Data Centre) using your user id as input.

Stephen

Former Member
0 Kudos

Hi

I went to the data center and could not find the data element UserPopulationInfo.

Can you tell me which options that you selected in the data center to test the data element?

Thanks,

Regards,

Joao Regalado

StephenBurr
Active Contributor
0 Kudos

I was going from memory but I've just checked and you can't!

Even though it is using NakisaRFC (aka OTF) the "UserPopulationInfo" data element (that uses "OTFSchema\SAP_UserPopulation") is not listed. 

However, it calls function module "/NAKISA/RFC_REPORT" so I recommend that you set an external breakpoint in SAP for this function module and find out what is being passed back to OrgChart.

Stephen

Former Member
0 Kudos

Hello Stephen,

  

I have already set an external breakpoint for the user novabase6
(user that i logon in Nakisa) but nothing happens, i was expecting that
the function module starts the debug console.

  

In attatched follows the print of the breakpoint.

Can i assume that the function module  /NAKISA/RFC_REPORT it
is not being invoked?

 

Many thanks,

João Regalado

lukemarson
Active Contributor
0 Kudos

Hi João,

Do not request the phone number and email of forum posters. This is against forum rules. In the next instance of an offence your posts will be deleted.

Do read the forum rules of engagement. You must provide the version of the application you are using. http://scn.sap.com/docs/DOC-26983

What version of OrgChart is this? For SP1 refer to the Admin Guide to make the customization, otherwise if it's SP2 or SP3 then it should work. I would recommend opening an OSS because this feature should work by just making the config change that you did.

Best regards,

Luke

StephenBurr
Active Contributor
0 Kudos

Are you logged onto the SAP GUI with the same user id... check the SAP GUI settings to ensure that user id is being used for debugging.

Stephen

Former Member
0 Kudos

Hi Luke,

I'm sorry but i didn't offend no one.

Acording to the link you provided I will refresh the product information, however my version is 3.0 SP3.

We use this forum to accelaret the process of getting answers to our questions, because we have deadlines very restrict.

Attending to this situation i would appreciate the help of all the community.

Can you please help us to grant that we have already made all the possible tests that could possibly solve this issue before creating OSS message?

Best Regards

João Regalado

StephenMillard
Active Contributor
0 Kudos

João.

Have you tried taking it back to the minimal 'out of the box' sort of configuration?  It isn't clear how much configuration/customisation you've done with the build you are having issues with.

By "back to the minimal 'out of the box' sort of configuration" I mean take a new configuration build, configure to connect to SAP and draw out a chart with a shared top level root ID.  Once you have this working change the config to draw the root from the user's own node (i.e. the change referenced earlier in the thread).  Make no further changes.  Does the root still fail to be drawn? If so go back and review the cds.log again.

This will be a useful activity even if you are raising an OSS, so if you haven't done this yet it is well worth doing so.

Stephen.

Former Member
0 Kudos

Hi Stephen Millar and Stephen Burr,

Many thanks for all help.

Really i don't know what was the problem. But now is solved.

I start with a new build without any configuration and do the basics configurations has you suggested and now works.

If i discover the issue i will post it here.

Best regards

Joao Regalado

Former Member
0 Kudos

Hi All,

This is regarding the issue I am facing in Succession Planning, When I select the 'Orgchart root value source' as 'user record', the field 'User record field' is enabled, but the Dropdown does not contain any Values. Am I missing any configuration in Admin Console of Succession Planning?? Please Help!!!

Regards

Bharti

Former Member
0 Kudos

Hi Bharti,

I'm not a expert but try to edit on xml or go to next step ando go back again. could be a little bug.

Regards,

Joao Regalado

Former Member
0 Kudos

Hi Joao,

thanks for a quick reply.

I am facing this issue incase of CP & SP, Org Chart is working fine.

If I am not wrong, this dropdown should be enabled in all....rite.

Regards

Bharti

lukemarson
Active Contributor
0 Kudos

Hi Bharti,

You should not maintain a root OrgUnit in SuccessionPlanning.

Best regards,

Luke

Former Member
0 Kudos

Hi Luke,

Kindly guide me what should be configured in the Admin Console of Succession Planning.

I assume, if I choose Root Org Unit, it would display the Org Structure under 'My Work Areas', 'Employees' & 'Positions'. Now if i want to display the Org Structure as per the  user, i will have to choose 'User Record' setting in Admin Console (as done in Org Chart).

Regards

Bharti

lukemarson
Active Contributor
0 Kudos

Hi Bharti,

Please refer to the Admin Guide for SuccessionPlanning. IF you have further problems please open a new thread.

Best regards,

Luke

Answers (0)