cancel
Showing results for 
Search instead for 
Did you mean: 

OCRY doesn't display.

0 Kudos
82

Hi,

I am trying to display "OCRY, Name" using BP address fields individually. While i can display all the rest, the table OCRY doesn't display nothing upon preview. Is there something i need to change in the settings?

I have checked the address formats and others but there's no issue with it or the pld, how can i make it appear?

thanks

praveen

Accepted Solutions (1)

Accepted Solutions (1)

former_member325312
Active Contributor
0 Kudos

Hi Praveen

S u can get the Country name in the PLD

Go to Administration -


>System Initialization-->Company Details-> On General Tab -


>U find a Filed Country Enter the Country Name and U can call that Country Name in any PLD

1).Take One Database field = F_100 = -


> Table Name----->OADM

ColumnName -


>Country

2).Take One Text Filed = F-101 = INDIA

3).Take One Formula field = F_102 = F_100 ==F-101

4).Take One Text Filed = F-103 = INDIA & link this filed to F_102

Now u will get Ur Country Name in ur PLD

I think this will solve ur probelm If then pls do close the thread

Regards

Jenny

Edited by: Jennifer Anderson on Jun 11, 2010 7:38 AM

Edited by: Jennifer Anderson on Jun 11, 2010 7:43 AM

Edited by: Jennifer Anderson on Jun 11, 2010 7:43 AM

0 Kudos

Thank you so much Jenny, I did something similar but the thing is..i am calling a financial Statement of Account report where the country is tagged to BP address and the BP address will always changes together with the country itself, also it displays only the country code which i can't change. Since this table OCRY is available, i utilized it however it doesn't display the field content at all.

Any other settings that i need to do perhaps?

regards,

praveen

Answers (1)

Answers (1)

former_member206437
Active Contributor
0 Kudos

Hi

Do u wana to Call that table in PLD then Use ALT + CTRL and Press Drop Down on Table it will show all tables in DB..But SAP is not supports to use this way...

Best way u can use Crystal Report for the Print instead of PLD..........

Giri

0 Kudos

I can see the table Giri, but the problem is the content is not being displayed on to the pld.

here's what i am attempting to do which is to call a report

Reports->Financials->Accounting->Aging->Customer receivables aging->(Customer Statement Report,one customer)

Now what i did was to draw fields of the BP address from OCRD (Street, block, county, zipcode etc) but when its the country & state, the output only shows me codes instead of full addresses from that table name. I tried to check on the description and do some formulae but doesn't work as every BP has a different country presence inthe report so i cannot utilize the one coming from the Administrative address (OADM table).

What i instead did was to try and display the OCRY & OCST tables for country and states respectively on to the PLD form but the problem is..there was no output upon preview.

I am stuck right there coz i know its a settings issue as it works on my other test environment this way but not here. Now i where to change these settings is what i need to know.

I have tried, Address formats, country formats, checking Administrative address, BP master data but i just can't pull it out on my live db. So i need help on this.

please advise.

regards,

praveen

ashutosh_tomar
Contributor
0 Kudos

Parveen,

Are u able to pick the country code and state code?

T & R

Ashutosh

0 Kudos

HI Ashu,

Thanks for response, Pick from which table you mean?

OCRD, yes

OCRY & OCST can't

thanks

praveen

ashutosh_tomar
Contributor
0 Kudos

Parveen,

It is not getting done. Try some other option rather than PLD.

Regards

Ashutosh

0 Kudos

The thing is, it worked on my other test database but not this, i need to know where i could do any change in the settings to get it rectified.

thanks

praveen

ashutosh_tomar
Contributor
0 Kudos

Is the SAP version same ?

I tried it out on SAP 2005B pl 34, and 8.8PL 11.

How you did it in your test DB?

Regards

Ashutosh

0 Kudos

i am using 2007A patch 49 SP00

I just displayed those fields on the test database and it shows up but not on the live. So i am sure its just some silly settings issue. which i can't seem to figure out.!