cancel
Showing results for 
Search instead for 
Did you mean: 

Notification set in process again at defect recording

Former Member
0 Kudos

Hi all,

In customizing, my inspection type is defined as "one Q-notification by inspection lot".  The linked notification type is A1.

I created an inspection lot.  I created a notification of type B1 with QM01 link to this inspection lot (QMEL-PRUEFLOS).  This B1 notification is already closed.

When I record an defect in QE51N for this inspection lot, a new A1 notification is created BUT the closed B1 notification is set in process again.

Is there a way to avoid this kind of behavior ?  I just want to create a new A1 notification without reopening the closed one.  Eventually just reopen existing A1 which are already closed but not other type of notifications.

Thanks in advance

View Entire Topic
former_member221025
Active Contributor
0 Kudos

Hello Sebastien,

"one Q-notification by inspection lot" applies to Inspection lot only irrespective of Notification type and it will set other notifications in-process if you record new defects.

In your case i guess both A1 and B1 are customized notification types. And in B1 notification you have incorporated "inspection lot" field by using some Exit.

When you create manual notification B1 using QM01, you enter Inspection lot number and it hits Table QMEL. Now when you record defects and create notification A1 system gets another Notification with the same inspection lot number and puts it In-Process.

Now if you consider standard notification types F2, Q2; When you go for QM01, you can not maintain Inspection lot number in Q2 notification, but for F2 (Automatically) system copies inspection lot number into notification. And as it does not get any other entry in QMEL there is no effect on Q2 notification created earlier.

Experiment on user Exit QQMA0030  Check validity of status change; and see if you can restrict putting notification in-process if Notification type is Not Same. 


Amol.

Former Member
0 Kudos

Hi Amol,

That's exactly what I did.  I will investigate on Exit QQMA0030.

Thanks a lot.