cancel
Showing results for 
Search instead for 
Did you mean: 

material number ranges

Former Member
0 Kudos

Material Master External Number Range that allows numerics only and combo of numerics, Alpha and Characters

I have the following issue. My client wants to use a purely External Numbering System in SAP

- They only use one Material Type (HALB).

The range must be able to manage material numbers that:

1. Are up to 18 CHAR

2. Have Leading Zero's(Numeric Only) - example 0123, 0000223, etc

3. Purely numeric (no zeros) - ex 56788, 1235456

4. Have Leading Zero's with (Alpha Numeric) - ex 00A456

5. Alpha numeric (No Zeros) ex T123542

6. Leading Zero's with a '.' in the Mat Number

Four examples

005.009.23

0000A.123.5544 M1

000.593.33234

0.1234

I have the Lexiographical Setting Checked

Leading Zero's Checked

Range is - 000000000000000000 to ZZZZZZZZZZZZZZZZZZ

The issue I have is with the last two examples in 6 above 'Leading zero's with a '.' in the Mat Number.

It seems the system has an issue with zero's then a decimal point without having another number of letter in between. It will allow 00000002.1223 but not 000000.1223. The only way I can get the system to take the leading zero then '.' entries is to check 'X' the 'External Number Assignment w/o Check in the Material Type HALB. When I do that I am no longer allowed to create purely numeric numbers. Any help?

Creating another material type is not an option. Also the '.' can be in any position in the layout.

Thanks in Advance!

--irfan

Edited by: Csaba Szommer on Jan 6, 2012 3:20 PM

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

am sorry m=but my question is totally different from the above link

thanks

sjeevan
Active Contributor
0 Kudos

Your problem can be addressed in two ways:

Solution 1: Remove the number range assignment for external number range and in the transaction code S_ALR_87002312 , check the box "External no. assignment w/o check".

Solution 2: Since the ascii and/or unicode values of period (.) is lower than zero you need to include that in the number range. So you need to change the number range from


Range is : 000000000000000000 to ZZZZZZZZZZZZZZZZZZ 

to


Range is : ------------------ to ZZZZZZZZZZZZZZZZZZ 

(All hyphens)

ASCII and UNIcode tables for reference

http://www.asciitable.com/

http://en.wikipedia.org/wiki/List_of_Unicode_characters

Also look at my previous replies to get better understanding so that you have more flexibility in defining number ranges

Answers (1)

Answers (1)

Lakshmipathi
Active Contributor
0 Kudos

Check this thread where it has been discussed already for the same requirement

[Re: How to configure Alpha Numeric No range for the Material Type|;

G. Lakshmipathi