cancel
Showing results for 
Search instead for 
Did you mean: 

LSMW for Asset Transfer: No Batch Input data for screen SAPLAMDP 0100

0 Kudos
1,277

Created LSMW for Asset Transfer (Transaction ABUMN)

If the input file has single record then I don't see any error, but if it has multiple records then I am getting the following error:

No batch input data for screen SAPLAMDP 0100

I verified the screen recording and field mapping a zillion times. No inconsistency.

Looking at different forums I see for some transactions Batch Input runs differently in background and foreground. Apparently it accesses screens in different sequence.

Has anyone faced this problem? I know we can go with BDC, but has anyone found success with LSMW?

Appreciate if anyone can share their experiences.

Thanks,

Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Wrote BDC program.

0 Kudos

Screen 0100 is the main screen number. The initial pop-up window where it asks for company code is screen 0300.

I tried both versions - with company code and without company. But keep getting same error when the input file has multiple records.

Former Member
0 Kudos

Perhaps it helps when you fill in your use parameters BUK = xxxx (your cc number)

Former Member
0 Kudos

When you have the error what is it asking in that screen, what is this screen?

Some time's you have only the first time a screen to set company? Then you do this manual before you start the BDC.

Dependend of the settings in a asset class / transaction type it is possible that you can get different screens