Showing results for 
Search instead for 
Did you mean: 

lsmw - CL02

0 Kudos

when i tried to create legacy for batch input in tx CL02, im getting error as "No batch input data for screen SAPLCLMO 0100". I tried recording thrice, im getting the same error. all other fields are working fine. help me out resolving this error.

Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

there is no need to do a recording as SAP has developed standard import methods for this activityin LSMW:


standard batch input

Object 0140 Class

Method 0000

Programmname RCCLBI01

and IDOC method

message type CLMAS

basis type CLFMAS02

now to the error you receive 'No batch input data for screen SAPLCLMO 0100'

in SE51 you can enter SAPLCLMO and dynpro 0100 and display the layout.

you will see that this is the initial screen of transaction CL02.

did you miss to define the fields? did you miss to do the field mapping and move values to the fields?

0 Kudos

i have defined all the fields, even i mapped correctly. but the problem is wen i run the batch input, In the very first step itself it gives that warning. i checked the recording part its fine. Is there any issue with configuration part as im working on training system? or is it the problem with my recording part?

Former Member
0 Kudos


If you successfully processed one record manually (when you performed your recording) then there is no problem with your configuration. The problem lies in your recording, or with your load data.

Unfortunately, I have never tried to do Class maintenance in LSMW using a recording, so I can't comment further.

Best Regards,


Answers (1)

Answers (1)

0 Kudos

The recording must pass twice for screen SAPLCLMO 0100 'but then in the recording you must delete manually in the second pass:



Just leaving the:



As I show in the attached photo.

0 Kudos

How the screen SAPLCLMO 0100 can be added to the LSMW record?