cancel
Showing results for 
Search instead for 
Did you mean: 

Loans Dedcutions

Former Member
0 Kudos
257

Dears,

Good Day,

i faced some issues when implementing loans

kindly check and feed me back

the master data configured as below

but when run payroll the loan payment was generated with positive amount not negative

so my questions How generate this values with negative amount

regards ,

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Dear Experrts ,

any solution for this error ,

antoine_foucault
Active Contributor
0 Kudos

Amin:

In the third tab, 0150 Loan payment via payroll is made to give the loan money to your employee.

If you gave the money to that employee outside of the payroll you use 0100 loan payment (external) with amount 1,000.000 EGP. Then could you try to the second tab and fill repayment start date with a proper date and repayment amount with 200.00. Consider periodicity of your reimbursement.

Here is a table for use of payment type.(taken from SAP documentation PYSOME_LOAN.PDF version 4.6c)

Best,

Antoine

Former Member
0 Kudos

Dear Antoine ,

Thanks for your detailed explanation

now when running the payroll i faced the below issue

and i tried to find solution but still exist

Best Regards ,

Former Member
0 Kudos

Dears ,

ِAny advice ?

BR ,

former_member193210
Active Contributor
0 Kudos

In what Payroll Period (PP 2017.XX in PP 2017.YY) is that error happening?

Execute Payroll again for that employee, with the "Display log" box checked, then double clic on Function P0045 when you have the error on screen, and post the information provided (Input from IT0045 and processing).

Former Member
0 Kudos

Dear Remi ,

check and feed me back ,

former_member193210
Active Contributor
0 Kudos

In what Payroll Period (PP 2017.XX in PP 2017.YY) is that error happening?

From what I can see, the Basic Data from the employee's Loan (IT0045) is the same as in your initial screen capture, but the Car Loan Payment (IT0078) has a "Payment Date" that does not match what was in your initial screen capture of the Payment tab of the Loan.

Have you added any parameters in the "Conditions" tab of the employee's Loan?

Former Member
0 Kudos

Dears ,

any suggestions ,

former_member193210
Active Contributor
0 Kudos

I'm a bit confused by your screen captures, but it could be because we do not use IT0045 (Loans) or IT0078 (Loan Payments).

Your screen captures seem to imply that the employee has been approved for a Loan of 1000 EGP, that he/she has already received 200 EGP, and that the schedule of future payments is on the 21st of the month, from January through April. But under the "Loan conditions" tab, there are no "Indiv. interest rate" nor any "Effective interest rte", no "Repayment start" Date, and no "Rpymnt instl." Amount

The Loan should be a Payment (positive), while the Loan Repayment should be a Deduction (negative), and they many not be using the same Wage Type. Through transaction spro, look at your configuration under Payroll: your Country(is it Egypt?) > Loans.

Former Member
0 Kudos

Dear ,

Thanks for your replay

what is your alternative process for employee loans