cancel
Showing results for 
Search instead for 
Did you mean: 

LIS - S962 delivery report is updating wrongly.

Former Member
0 Kudos
101

Hi SAP gurus,

We have LIS report for Delivery documents on PGI (goods issue ) dates.

when we run this report the goods issue date is captured wrongly.

when we run this report for certian PGI period Eg:- 05/10/2010 to 06/10/2010, report will display the delivery documents on date 00/00/0000 -


05/10/2010 -


06/10/2010 -


in the above example 00/00/0000 will capture the Delivery documents which are not PGI'ed (Goods issued) and the rest of the date like 05/10/2010 and 06/10/2010 will show the delivery documents which are PGI'ed on those days.

my issue is the same delivery documents is shown in 00/00/0000 and 05/10/2010 dates since those sre PGI'ed on 05/10/2010.

where as the 00/00/0000 date should show only documents which are not yet goods issued.

I will appreciate if any body can assist me in resolving this issue.I'm also new to LIS part and dont know how to where to check this. Please guide me with transaction codes.

Regards,

Nag..

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Gurus,

Can any body through some light on this issue, I will be great full to you.

Regards,

Nag.....

Former Member
0 Kudos

Hi Gurus,

Please help me in this issue....

Regards,

nag

eduardo_hinojosa
Active Contributor
0 Kudos

Hi,

Try to set the condition 104 (report FMCV1104) in the updation of your infostructure. You can see that the coding is:


form mcv1_104.

  clear returncode.
  if mcvbup-wbsta <> 'C'.
    returncode = 4.
  endif.

endform.

ie: if the status of PGI is not equal to C the data is not updated.

Check that it works with tcode MCVT.

Regards,

Eduardo

Former Member
0 Kudos

Hi Eduardo,

Can you please guide me in which transaction code this changes to be done or in which Path.

The PGI date is a character in this report, even though can we set this routine ?

Thanks foryour help in advance....

Regards,

Nag.

eduardo_hinojosa
Active Contributor
0 Kudos

Hi,

Check it in the updation of LIS in tcode MC24 / MC25. To create the subroutine tcode MC1B.

Regards,

Eduardo

Former Member
0 Kudos

Hi,

Since PGI is a character in the LIS report we can not assign requirement 104 to it.

My client needs to see the report on PDI date wise deliveries.

In this report delivery is not getting updated on PGI date.

-when I create delivery document with out PGI, this document number will be shown against 00/00/0000 date where ther is not PGI happened and this correct.

- When I create PGI with warehouse managed with TR and TO on 01/11/2010, PGI date updated in the delivery document as in the LIKP-WADAT_IST.after this if I run LIS report the delivery document is shown in two PGI dates i.e 00/00/0000 which is not PGI'ed and also in the date 01/11/2010 which on PGI'ed.

- when I delete the documnet from the LIS structure and re upload the data, the Report is showing the correct data which the delivery document is shown against 01/11/2010 data only which is correct.

In my thinking the data is not getting updated, can you please tell me whether there is any update programe exist or how to solve this problem.

Many thanks in Advance.......

Regards

Nag.........

Former Member
0 Kudos

Hi All,

Can any body through some light in this issue...

Regards,

nag..

eduardo_hinojosa
Active Contributor
0 Kudos

Hi,

Perhaps you need to think how to built this LIS. with data of good issues (03) and instead from sales documents (01).

Regards

Eduardo